The wifi crusade.

Howard Coles Jr. dhcolesj at
Sun Apr 2 13:27:57 UTC 2006

On Saturday 01 April 2006 07:00, tchize wrote:
> Hello,
> Today, i decided to buy a wifi PCI card, to get rid of this nice wire
> in the house. My laptop was already using wifi, it was time for my
> upstair desktop to go wireless. I have a reflex when it comes to brand
> new card when they do not seem automatically working on my linux box:
> test how the manufacturer drivers behave on aimed OS (mainly windows
> for most) to ensure the card is not defect.
> Windows installation: put that awfull driver CD in tray, install
> drivers, go to the wifi configuration panel just click 'scan' and then
> give your password for the select wifi gateway (and specify the
> encryption type). Total time of operation from install driver to use
> browser: 5 minutes.
> Kubuntu installation: Drivers is recognized immediatly by kernel
> (rt2500 card) and loaded (great!). I go to kde network config panel
> and .. Outh, forgot that panel is not working in breezy badger, so i
> go to the net, find some tutorial and go by hand in
> /etc/network/interface.
> I add this:
> iface ra0 inet dhcp
>         pre-up iwconfig ra0 essid Ayato
>         pre-up iwconfig ra0 mode Managed
>         pre-up iwpriv ra0 set Channel=8
>         pre-up iwpriv ra0 set AuthMode=WPAPSK
>         pre-up iwpriv ra0 set EncrypType=TKIP
>         pre-up iwpriv ra0 set WPAPSK="<my key>"
>         pre-up iwpriv ra0 set TxRate=0
> Parameters AuthMode, WPAPSK, TKIP and the key is exactly the same i
> used under window
> Then i type
> tchize at Urd:~$ sudo ifup ra0
> Internet Systems Consortium DHCP Client V3.0.2
> Copyright 2004 Internet Systems Consortium.
> All rights reserved.
> For info, please visit
> sit0: unknown hardware address type 776
> sit0: unknown hardware address type 776
> Listening on LPF/ra0/00:08:a1:98:d4:c3
> Sending on   LPF/ra0/00:08:a1:98:d4:c3
> Sending on   Socket/fallback
> DHCPDISCOVER on ra0 to port 67 interval 7
> DHCPDISCOVER on ra0 to port 67 interval 15
> DHCPDISCOVER on ra0 to port 67 interval 15
> DHCPDISCOVER on ra0 to port 67 interval 13
> DHCPDISCOVER on ra0 to port 67 interval 7
> DHCPDISCOVER on ra0 to port 67 interval 4
> No DHCPOFFERS received.
> No working leases in persistent database - sleeping.
> Ok, i wasn't able to get a dhcp lease from wifi gateway. (note, i
> tried with a static ip too, no help in getting connect)
> to ensure driver is working properly , i issue a network scan:
> tchize at Urd:~$ iwlist ra0 scanning
> ra0       Scan completed :
>           Cell 01 - Address: 00:11:50:7E:F5:68
>                     Mode:Managed
>                     ESSID:"Ayato"
>                     Encryption key:on
>                     Channel:8
>                     Quality:61/100  Signal level:-65 dBm  Noise
> level:-193 dBm
> So the driver itself is working properly.
> Total time: 3 hours work, attempting various config, i am still not
> able to connect  to wifi gateway and no error message at all to
> provide informations on what could be wrong, except the fact dhcp
> don't get a lease! The wire cable is still there...
> Conclusion: If you want to go wifi go windows or mac os x?
>  I hope not! Does someone has a solution to this problem?
> Thanks.

First:  Install wpa_supplicant (if it supports your wireless card).
Then do the following
1st, go to /etc/default and edit wpasupplicant according to the examples.
(for example:
OPTIONS="-ira0 -c /etc/wpa_supplicant/wpa_supplicant.conf -D<yourdriver>" )
-i is the interface you're wanting to config.
-c is where your config file is
-D is the driver

2nd, edit /etc/wpa_supplicant/wpa_supplicant.conf and put in something like 
the following:

	psk="yourkey here"

3rd, edit your /etc/network/interfaces file and remove all the stuff you had 
there so that it looks like this:

auto ra0
iface ra0 inet dhcp
# pre-up /etc/init.d/wpasupplicant start
# pre-up sleep 5

The pre-up lines MAY not be needed with your system, try it without them.  If 
wpasupplicant doesn't load you can uncomment them and your card should 

You MAY also have to  add a soft link in /etc/rcS.d as I did like this:
ln -s /etc/init.d/wpasupplicant /etc/rcS.d/S36wpasupplicant

to get it to work.  (the command line above will work no matter what your 
current working directory is)

Try those things and let the list know if it still doesn't work.  I've been 
noticing in Dapper a on again off again pattern with wpa_supplicant packages, 
so that in and of itself may be the problem.


See Ya'
Howard Coles Jr.
John 3:16!

Christian Books On-Line

More information about the kubuntu-users mailing list