all my experiences and problems with kubuntu so far

Sander van Loon svloon at
Mon Apr 11 14:40:25 CDT 2005

First of all, I'd like to thank the (K)Ubuntu developers for their work. It's 
a nice distro, but in the three days that I'm using it I've encountered tons 
of problems.
I think that it would be a good idea to start a Kubuntu counterpart of For example to explain how we need to install the windows 
codecs for kaffeine, flash for konqueror and such things. Is such a thing 
already in the works?
I've written a long story about my experiences with Kubuntu. I don't know who 
are to “blame” for the many bugs I describe here, the Kubuntu team or KDE. I 
think it's both, so I'll post this here and in the KDE bugzilla/mailinglists 
as well.  I hope the Kubuntu developers check this forum, or do I have to 
post in some mailinglist then? 


The installation could be easier with a GUI. Most of the other distro's have a 
Gui installer by now, but Kubuntu still uses a text based one. Not that I had 
much problems, but I this scares of newbies. 
I also noticed a bug in the installer, when I wanted to select my keyboard 
layout, I was looking for “Dutch” in the alphabettically sorted list. I was 
looking near the “D”, but I didn't found it there. So I scrolled down to the 
“N” for “Netherlands”, and there I found “Dutch” between “Norwegian and 
After that I had to do the partitioning. Maybe it would be a good idea to let 
the installer do this automatically? Please at least let it recognize the 
partitions of already installed Linux distro's. I had Fedora Core 3 
installed, but I had to manually edit the partitioning scheme so it would use 
those partitions. Maybe it would also be possible to implement the resizing 
of NTFS partitions, like the SuSE Linux installer?
After the base system was installed, I had to type my user name. I typed some 
letters, pressed Backspace because I made an error, I kept Shift pressed 
because I wanted to type a capital letter, and then the installer froze. It 
didn't respond to anything, except Ctrl+Alt+Delete for a reboot. I had to 
install a second time, but now everything went fine, fortunately.


amaroK freezes when I try to play a stream, a winamp .pls file. I had this 
problem when I tried to play the stream of I 
haven't tried any other streams though.

Enemy Territory

I installed Enemy Territory. It works fine, but when I exit it, my desktop 
“doesn't fit in the screen” anymore. I run my desktop on 1280 x 960 and Enemy 
Territory runs in 1024 x 786. I thinks that's the cause, the different 
resolutions. But I've been doing the same on Fedora Core 3 and then I didn't 
have this problem. So in other words, before I start & exit ET, my desktop is 
fine. I can see it completely. When I exit ET, I can't see it completely 
anymore, and I have to move the mouse pointer to the bottom of the screen so 
that I can open the menu and end my session. When I log in again my desktop 
looks normal again. I fixed this with setting a custom resolution of 1280 x 
960 in a .cfg file (can't choose that resolution in game), then this problem 
doesn't occur.
Another problem is the “jumping icon”. When I start programs in Kde, their 
icons jump near the mouse cursor. The problem is that that this jumping icon 
doesn't stop when ET is loaded, I can still see it in the menu. Fortunately 
it disappears when I'm playing, but it's quite annoying.
Another thing which is driving me mad is the permissions. I noticed I didn't 
have the permission to write to /.etwolf in my users home dir because I 
couldn't edit my config file! If that directory is installed in my home dir 
I'd expect that root wouldn't be the owner. I installed ET with sudo sh, could be that the cause of the strange permissions? On 
Fedora I used su, gave my password and then used the same command, and with 
Fedora I didn't have any problems with permissions.


After installing I installed a font, I could use it in OpenOffice, but I could 
not use it in the KDE Control Center. After I rebooted they did appear in the 
Kde Control Center and they were usable. Why is it not mentioned that you 
have to reboot first then?

Fonts anti aliasing

With anti aliasing on my fonts don't look very good. Check this screenie. Look carefully and 
you'll see that in Konqueror, the “W” in “Window” is very pixelated. It looks 
like this everywhere in all KDE apps. But in the OpenOffice window, the fonts 
are perfect, and the “W” is not pixelated. So anti aliasing doesn't work very 
well in KDE, but in non-KDE apps like OpenOffice it does work? How can this 
be fixed so anti aliasing looks better in KDE? I googled for an answer on 
this, I tried disabling “Hinting style”, but it doesn't make any difference.

Mouse cursors

I didn't like the default cursor theme, so I decided to install the Grounation 
cursor theme which can be found on I tried the cursor installer 
which can be found in the KDE Control Center under Peripherals -> Mouse -> 
Cursor Theme. I selected the file I downloaded to install it, but it 
told me that 14484-Grounation-0.3.tar.bz2 wasn't a valid cursor theme. I 
googled for a solution and extracted the cursor theme 
to /usr/X11R6/lib/X11/icons/. Now it appeared in the KDE Control Center and I 
could use it. But why is the installer telling me that the cursor theme was 
invalid? Did I have to extract the file first?

Setting my Logitech Dual Optical to 800 cpi

In Linux my Logitech Dual Optical Mouse is always defaulted to 400 cpi, but it 
is capable of 800 cpi. I've always used this program - - to switch it to 800 cpi. But 
I also noticed thisin the KDE Control Center - – so it seems that KDE can 
switch it to 800 cpi for me now, which is a useful feature. Unfortunately it 
won't work yet, as you can see.


Kubuntu is so very unstable for me. I removed an MSN contact group in Kopete, 
and it immediately crashed. When I close Kaffeine when it's playing a video 
file, it crashes. Konqueror crashes when I go to and watch 
a trailer and press the back button. I've never had this with any other Linux 


I followed the instructions mentioned in some forum posts, and extracted the 
codec pack essential-20050216.tar.bz2 to /usr/lib/win32 so that I could use 
Kaffeine to watch windows media, real and quicktime streams. Now I can view 
the quicktime streams on, but when I try to view windows 
media streams, for example on this page – (click on “(BB)” there) – 
Kaffeine says that there is “no plugin to handle this resource” (that happens 
with the windows media streams on that website, but there also are real media 
streams which give the same result), and Konqueror crashes.

I've mentioned a lot of problems here, some are driving me so mad that there 
have been moments that I considered switching back to Ubuntu/GNOME, but I do 
appreciate Kubuntu. I just hope these bugs get fixed soon..
BTW, is there any KDE bittorrent client available which can compare to 
Azureus? Or aren't there any serious alternatives available and am I forced 
to use Azureus? I've searched a bit but I haven't found any mature projects.
One last thing, I noticed the useful Google search bar in Konqueror. Is it 
also possible to add search plugins for wikipedia, like it is possible in 

More information about the kubuntu-users mailing list