testers needed for plasme-widget-networkmanagement (again)...

Zorael zorael at gmail.com
Sat May 1 16:08:28 BST 2010

On Fri, Apr 16, 2010 at 1:07 AM, Sebastian Kügler <sebas at kde.org> wrote:
> On Thursday, April 15, 2010 22:10:46 koso wrote:
>> I have found a little issue with plasmoid.
>> Sometimes (very rare) it simply stops displaying available connections.
>> I can turn on/off interfaces, but list of connection (right hand side of
>> plasmoid) is still empy. I tried to click on VPN icon, where is similar
>> connection list dissappearing bug .. but it did not help. I have also
>> tried to remove plasmoid from tray and add it back .. problem was still
>> there. When I start another instance of plasmoid (using plasmoidviewer)
>> it works, so it is probably not problem with backend. Maybe some "bad"
>> state? Or  list is only invisible?
>> Anyone with the same problem? I am using plasmoid full-time for more
>> than 6 weeks, and it happened only 2 times. Only fix I found was logout
>> / restart.
> When this happens next time, can you try to reload the networkmanagement kded module:
> qdbus org.kde.kded /kded loadModule networkmanagement
> ... and then let me know if that helps?

I just had this happen to me and remembered this mail, so I dug it up
and tried the command you suggested. I am in the vincinity of a
wireless network that I have set up to connect to automatically, and I
have one PPTP VPN connection set up (but not connected to). Both
should show up in the connections list, and neither does. VPN is not
even listed in the interface column (which it also should be). But I
/am/ connected to the wireless. Another thing to note is that I have
suspended and resumed the machine this session.

Reloading the module, if that's what happens when you load it while
it's already loaded, did not help. I didn't seem to lose my net
connection, but the wireless networks didn't appear in the list

Unloading and loading the module didn't help either. I naturally lost
connection when the module went down, and it automatically reconnected
me to my wireless network when it went up again - but the connections
list remains empty and the VPN interface still hasn't shown up.

Closing and restarting plasma-desktop didn't help this time, though I
remember it being a valid workaround earlier; perhaps it's just
finicky. The VPN interface now shows up and has the subtitle Not
Available. KVpnc can properly connect to it, suggesting I'm not
lacking the libraries and daemons for it.

Lastly, opening the widget up in a plasmoidviewer with 'plasmoidviewer
networkmanagement' makes the new instance also show an empty list.

This is with plasma-widget-networkmanagement version
0.9~svn1112085-0ubuntu4 from lucid main, with all other packages up to
date as of 2010-05-01.


More information about the kubuntu-devel mailing list