wpa and broadcom card

chuck adams chuck.adams.k7qo at gmail.com
Tue Oct 20 22:58:07 BST 2009

On Tue, 2009-10-20 at 08:53 -0400, Jonathan Jesse wrote:
...snip snip...
>         l
> I know the first time I rebooted after enabling the Broadcom card it
> showed it was activated but not configured.  rebooting a second time
> gave me no problems with wifi

Here is some of todays results.

o  ubuntu karmic-netbook-remix-i386.iso  dated 10/20/09 1449UTC (1549?)

lenovo s10 ideapad netbook with 2GB of RAM and 160GB harddrive

o  I found out there is a difference between starting with live 
   USB system vs. starting install from the bootup menu
   with the live USB the hardware is recognized, but activation results
   in error message "Sorry, the package "b43-fwcutter 1:012-1" failed
       to install or upgrade"

o  running live CD/USB system
   admin->hardware drivers results in showing Broadcom B43 wireless
drivers active and currently in use.  no wifi interface shown in 
wireless icon on the task bar.

   I ran ifconfig from terminal and it shows eth0 and lo, but no
other interfaces like wlan...

   I did 'sudo /etc/init.d/networking restart' and still same setup.


Now install system from live USB

   xxx  in installation and setting up user.  the netbook iso defaults
to AUTOMATIC USER LOGIN.  The two desktop iso's do not.  This seems like
an error to me.  The netbook is the most likely computer to be lost or
stolen from the owner and should not have 'automatic user login' as a 
default IMHO.  xxx

   xxx Also; at the finish of the installation procedure the language
support for wamerican, wbritish, ... are removed. Upon bootup of the
new hard drive system, there is an error window showing incomplete 
language support and it reinstalls the modules that were removed.
Strange behavior in my opinion, but what do I know?  xxx

o  reboot,  no wifi
o  go to admin->hardware drivers  Broadcom B43 shown
   o  plugin Airlink 101 USB wifi for internet connection
      - download and install drivers and firmware
   o  now Broadcom B43 wireless driver shown active and currently in use
o  do a shutdown and remove Airlink 101
o  reboot and still no wifi, even though admin->hardware drivers shows
   B43 active and currently in use
o  multiple reboots still do not get the interface active


Here's hoping the above gives you more information.  There is a
Broadcom STA wireless driver support and that sometimes comes up,
if I do an install and use the synaptic package manager.  Also,
I had a previous problem in not knowing that the b43-fwcutter
package also is needed and not installed automagically.  

Thanks in advance.  I'll try again tomorrow on the next rev
of the iso.

I think I read that ubuntu 8.04 supported the lenovo netbook 
and I am going to download and try it and every release since
then.  I have lots of time on my hands....

ciao dudes and dudettes,


More information about the kubuntu-devel mailing list