[Bug 1839432] Re: [CVE] malicious .desktop files (and others) would execute code

Launchpad Bug Tracker 1839432 at bugs.launchpad.net
Fri Aug 16 00:49:57 UTC 2019


This bug was fixed in the package kde4libs - 4:4.14.38-0ubuntu3.1

---------------
kde4libs (4:4.14.38-0ubuntu3.1) bionic-security; urgency=medium

  * SECURITY UPDATE: malicious .desktop files (and others) would execute
    code (LP: #1839432).
    - debian/patches/CVE-2019-14744.patch: remove support for $(...) in
      config keys with [$e] marker.
    - CVE-2019-14744

 -- Paulo Flabiano Smorigo <pfsmorigo at canonical.com>  Mon, 12 Aug 2019
12:04:10 -0300

** Changed in: kde4libs (Ubuntu Bionic)
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kde4libs in Ubuntu.
https://bugs.launchpad.net/bugs/1839432

Title:
  [CVE] malicious .desktop files (and others) would execute code

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kconfig/+bug/1839432/+subscriptions



More information about the kubuntu-bugs mailing list