[Bug 115970] Re: qt4 apps doesn't start with symbol lookup error

Nixblicker el_lunatico at gmx.net
Wed Apr 20 12:09:14 UTC 2011


Hey guys,

seems that i have solved this problem for me - i recently moved over to a newer PC, and our admin tried to recover as much software as possible from that has been installed previously. I didn't even knew i had GoogleEarth installed before, but it was now - and most likely this was really the culprit.
But there is absolutely no need to reinstall your entire system - i simply found duplicate (obsolete) copies of 
/usr/lib/libQtCore.so.4 
/usr/lib/libQtGui.so.4 
/usr/lib/libQtNetwork.so.4 
/usr/lib/libQtWebKit.so.4

in /lib - i guess this screwed the library linking in ld. So make sure you do not have duplicates in the Path, may it be /usr/local/lib or /lib or wherever.
All i did was to move those suspects to another folder not in the Path, update ld via "ldconfig" and all "undefined symbols" were gone.

Good luck!
Cheers, Nix

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to qt4-x11 in Ubuntu.
https://bugs.launchpad.net/bugs/115970

Title:
  qt4 apps doesn't start with symbol lookup error



More information about the kubuntu-bugs mailing list