[Bug 538639] Re: Support Application Indicators

Rémi Denis-Courmont remi at remlab.net
Sun Mar 14 08:02:23 UTC 2010

VLC currently uses the Qt4 API for systray.

There are roughly three paths to addressing your request:

1/ libQt4Gui takes care of it. As VLC upstream, that would have my
preference (then I have no extra work to do). But the Qt4 people might
think quite differently.

2/ The indicator application library is made suitable to replace the
current Qt4 systray in VLC upstream. That means it has to support
Windows, while not using glib, neither D-Bus (at least not on Windows).
I somehow doubt that this is going to happen. Also, it is utmostly
unlikely that VLC 1.2 would be ready in time for Lucid+1. By all
chances, Lucid+1 Universe will ship VLC 1.1 which is already feature-

3/ Have Ubuntu fork the VLC systray from upstream. I doubt the
Debian/Ubuntu Multimedia packagers would like this though.

** Also affects: qt4-x11 (Ubuntu)
   Importance: Undecided
       Status: New

Support Application Indicators  
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to qt4-x11 in ubuntu.

More information about the kubuntu-bugs mailing list