[Bug 217100] [NEW] Realtek RTL8187B cannot connect to WPA/WPA2 network

Launchpad Bug Tracker 217100 at bugs.launchpad.net
Tue Jun 3 03:11:56 UTC 2008

You have been subscribed to a public bug:

Binary package hint: network-manager

I'm using ndiswrapper with the vendors driver, and I'm trying to use my usb wireless card :
;; net8187b.inf 
;; Realtek RTL8187B Wireless 802.11g 54Mbps USB 2.0 Network Adapter

The access point is configured this way:
WPA: WPA-PSK (No Server)
WPA mode: WPA/WPA2 mixed mode
Encryption technique:  AUTO for WPA, AES for WPA2

I enter my ESSID chose "WPA personal" and use my Pre-shared Key (PSK) on nm-applet
It keeps asking the password and never connects. I also tried with "WPA2 personal" and other options and they all fail.

Is there a way to connect on WPA2 with this configuration on access point???
I'm sure I typed the (PSK) on the right place with the right value... did i had to type the generated key??? 
I tryed without the encriptation and the wireless card worked just fine so in think ndiswrapper is working ok.

I looked the windows configuration and it says its connected through WPA2, (AP says wpa/wpa2 mixed mode).
When I did some manual configuration through ifconfig, iwconfig the network manager lost the wireless networks options like they vanished ...
It became slower too, when trying to apply changes I have to wait several minutes

Im using Ubuntu Hard 8.04 beta

****************************************   Update

     Access Point: 3com officeconnect (model 3CRWDR101A-75)
     Network adapter:  Encore 802.11b/g wireless usb adapter (Chipset realtek RTL8187B)
     (There is also a  wired network card on pc)

Here is a file I used to get it working on slax (backtrack):

------From /etc/wpa_suplicant.conf ( on slax )
# See /usr/doc/wpa_supplicant-0.5.7/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
# By default, only root (group 0) may use wpa_cli

  proto= WPA2
  key_mgmt= WPA-PSK
------EOF /etc/wpa_suplicant.conf

the  syslog goes as attachment

** Affects: ndiswrapper (Ubuntu)
     Importance: Undecided
         Status: Incomplete

Realtek RTL8187B cannot connect to WPA/WPA2 network
You received this bug notification because you are a member of Kernel Bugs, which is subscribed to ndiswrapper in ubuntu.

More information about the kernel-bugs mailing list