[Bug 226941] [NEW] [ndiswrapper] network manager in roaming mode fails to connect to wpa network using ndiswrapper

Launchpad Bug Tracker 226941 at bugs.launchpad.net
Tue Jun 3 03:20:16 UTC 2008


You have been subscribed to a public bug:

Binary package hint: network-manager

This is sort-of a duplicate, except the other bug is marked invalid...
When using ndiswrapper under Hardy and trying to connect to a WiFi
access point using WPA and in roaming mode network-manager fails to
connect.  It tries and tries, but while the network LED indicates a
connection Hardy never completes the connection or even queries for
DHCP.

If taken out of roaming mode OR connecting to an open access point IN
roaming mode it works.

Hardy continues to ask for a WPA key over and over again when it fails
as well, indicating that it could be an authentication problem.  This
does not happen with the linux drivers for my card, which are flightly
(hence why I'm using ndiswrapper).

The card is a PCMCIA Ativa Wireless AWG54G card.  Linux identifies it as:
07:00.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)

It is connected via this:
02:01.0 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller

The laptop is a Dell Inspiron 8200 with 640Mb of RAM, 1.6 Ghz CPU.

The ndiswrapper driver should work, as it worked perfectly in Gutsy.  I
also tried compiling from source the latest ndiswrapper, this did not
appear to help at all.

What other information would be helpful?

** Affects: ndiswrapper (Ubuntu)
     Importance: Undecided
         Status: Incomplete


** Tags: encryption-wpa
-- 
[ndiswrapper] network manager in roaming mode fails to connect to wpa network using ndiswrapper
https://bugs.edge.launchpad.net/bugs/226941
You received this bug notification because you are a member of Kernel Bugs, which is subscribed to ndiswrapper in ubuntu.




More information about the kernel-bugs mailing list