[Bug 667468] Re: apt-get autoremove don't find all packages

Sworddragon 667468 at bugs.launchpad.net
Wed Sep 19 05:41:26 UTC 2012

> not enough information is presented about the packages involved to
determine whether a bug is present. The maintainer does not think so.

Too bad I haven't knewed on reporting this bug how to set the locale to
an english one because I was new to Linux this time. But even if the
maintainer can't clarify this report as a real bug it doesn't mean that
it isn't one. I have checked my attached log again and am sure that this
was definitely a bug. I will explain it again:

"apt-get autoremove alsa-utils" has tried only to remove alsa-utils.
Using directly after this "apt-get autoremove" has tried to remove
linux-sound-base (--purge was not needed for this. I don't know why I
have used it in the log). So linux-sound-base wasn't any recommended or
suggested package on my system. Theoretically the first command "apt-get
autoremove alsa-utils" should remove alsa-utils and find all
dependencies that are not recommended and not suggested to any other
installed package of my system and remove them. But apt hasn't done

This all is now ~2 years ago and the dependencies of alsa-utils has
changed so that I had to test it with other packages and apt-get
autoremove PKG will work as expected: It removes the given package and
does an autoremove after this.

> If you no longer experience an issue but can not identify where it was
fixed (i.e. the particular changelog entry) then mark it as either
incomplete or invalid. In this case it is not clear that there ever was
a bug so there can hardly have been a fix released for it.

It seems nobody has tried to fix this bug directly because he saw this
ticket. I have seen often tickets which was miraculous fixed after a
while. This is nothing special because some bugs are randomy fixed with
a commit. And in ~2 years there were surely many commits released which
had the chance to randomly fix this issue.

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to apt in Ubuntu.

  apt-get autoremove don't find all packages

Status in “apt” package in Ubuntu:
  Fix Released

Bug description:
  Binary package hint: apt

  I'm using Ubuntu 11.04 dev and apt 0.8.7ubuntu1. apt-get autoremove
  don't find all unused packages. For example if I install alsa-utils,
  linux-sound-base is installed as a needed package. If I try to
  autoremove alsa-utils, linux-sound-base is ignored. Only a second
  autoremove does remove linux-sound-base. I have made an example (it's
  in german because I don't know how to start apt in english but it
  should show the problem with the commands).

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list