help with installing browser and office as local apps on LTSP

Gavin McCullagh gmccullagh at
Wed Apr 15 14:08:20 BST 2009

On Wed, 15 Apr 2009, graydebowen at wrote:

> Now I get stuck,  sudo chroot /opt/ltsp/i386 apt-get install xterm 
> runs OK but changing the command to sudo chroot /opt/ltsp/i386 apt-get 
> install firefox or variations such as mozilla-firefox return couldn't 
> find package firefox.  

You might want to first run 
	sudo chroot /opt/ltsp/i386 apt-get update 

to make sure you have up-to-date lists of available packages.  Then get a
shell in the chroot with

	sudo chroot /opt/ltsp/i386

and run:
	apt-cache search firefox

If you don't get back a firefox package then maybe you have the wrong
sources available.  From within the chroot, send us the output of

	cat /etc/apt/sources.list

> I tried to sneak up on the problem and downloaded the open office rpm
> moved to it the chroot and tried to unpack it there.  No rpm icommand in
> the chroot (not a big surprise its pretty sparse in there).

Ubuntu is a debian-based system, so RPM isn't used.  You would want to
download a.deb file and install with "dpkg -i ...".  However, I wouldn't
recommend this at all.  "apt-get install firefox" is the correct way to do
it, you just seem to be missing some package sources.


More information about the edubuntu-users mailing list