help with installing browser and office as local apps on LTSP

graydebowen at graydebowen at
Wed Apr 15 13:47:16 BST 2009

In March Mr Koskinen demonstrated VLC running as a local app on Jaunty 
on this board.  

The basic instructions are at https://wiki.ubuntu.
com/LTSPLocalAppSetup and should work with 8.10.  There are expansions 
but both rely on there being instances of the required local apps on 
the chroot for the client image (/opt/ltsp/i386)

This example is given for xterm on the 1st link above:

sudo chroot /opt/ltsp/i386 apt-get install xterm
sudo ltsp-update-image

I should like to run the graphics and bandwdth heavy apps on the 
clients.  Clear candidates would be the gimp, firefox (or perhaps 
konqueror as less of a system hit) and open office (as the key 
component for client use).   This is as an alternatrive to the Nubae 
fat client approach.  

Now I get stuck,  sudo chroot /opt/ltsp/i386 apt-get install xterm 
runs OK but changing the command to sudo chroot /opt/ltsp/i386 apt-get 
install firefox or variations such as mozilla-firefox return couldn't 
find package firefox.  I also tried vlc (see the Koskinen post for a 
successful client vlc) but with the same result.  I tried to sneak up 
on the problem and downloaded the open office rpm moved to it the 
chroot and tried to unpack it there.  No rpm icommand in the chroot 
(not a big surprise its pretty sparse in there).

Cutting to the chase how do I get apps installed to the chroot 
directory path so that I can then use local-apps to run them on the 
client?  My main test machine is on 8.10 but I have a slower box on 
Jaunty if that will make life easier.

Grayde Bowen - Save £25 off a case of wine today

More information about the edubuntu-users mailing list