lucid unown user id LTSP user cant loggin

David Hopkins dahopkins429 at
Fri Aug 20 12:20:38 UTC 2010

I am using ubuntu 9.10 (karmic).  I held off upgrading because of some
concerns with moving to 10 immediately, including some issues with
ldap e.g.
I plan to update production servers to 10 over the Christmas holidays
after getting a test server fully operational at 10.  With school
opening next week, I won't have that done till mid-Sept.

I know that when I first tried to get ldap working with 9.10, it
didn't ... I had to use purge to completely remove the packages and
then load them a second time.

I found the following brief discussion of DRI and how to disable it:

Dave Hopkins

On Fri, Aug 20, 2010 at 2:22 AM, Mattias Hemmingsson
<matte at> wrote:
> Hi
> Yes i had everthing working fine in ubuntu 8.04
> But when i installed the new ubuntu 10.04 i cant logg in.
> The user can loggin with ssh but not throw the gdm.
> I onlyt get the unnown user error id.
> And i have tiried almost everything.
> Are you using ubuntu 10.04 ?
> // Matte
> ----- Ursprungligt meddelande -----
> Från: "David Hopkins" <dahopkins429 at>
> Till: "Mattias Hemmingsson" <matte at>, edubuntu-devel at, "Edubuntu Users List" <edubuntu-users at>
> Skickat: fredag, 20 aug 2010 1:18:41
> Ämne: Re: lucid unown user id LTSP user cant loggin
> On Thu, Aug 19, 2010 at 9:15 AM, Mattias Hemmingsson <matte at> wrote:
>> Hi
>> I have 4 ltsp server running lucid staddning.
>> But non of my ldap users can loggin to the servers.
>> The servers dump and unown user id and then sends the user back to loggin.
>> I have done som search and it seams to be cousing by somthing called DRI.
>> And I also find a buf saying that its not possible to turn dri off on the lts.conf file on lucid.
>> And that you have to set upp your own xorg.con file.
>> So i tried all this but still my users can logged in.
>> Is there any one using lucid with ltsp ans ldap and that has an working solution for this problem?
> Matte,
> I also use LDAP (Openldap). Scott Balneaves wrote up a tutorial on how
> to get authentication working a while back.  It can be found here:
> Follow the section for Client: install client pieces.  For my systems,
> I added just the ldap-auth-client.    I answered the questions. I
> changed the ldapi:/// to ldap://IP.x.y.z:389/ ... I also entered the
> correct info for the realm.  I answered yes to the question about
> having root be able to change passwords, and no for the authentication
> required to access the database.
> Next, I copied/pasted the example profile changing given on the above
> page, only I changed edubuntu to something appropriate for our school
> and saved it as ncs-ldap-config.
> I then invoked auth-client-config -a -p ncs
> Afterwards I was able to use ldap.  I now have 7 servers all
> authenticating successfully following this approach. Many thanks to
> Scott for help with that wiki page.
> Sincerely,
> Dave Hopkins
> --
> edubuntu-users mailing list
> edubuntu-users at
> Modify settings or unsubscribe at:

More information about the edubuntu-devel mailing list