.dmrc permissions?

Jonathan D. Proulx jon at csail.mit.edu
Thu Mar 23 16:55:20 UTC 2006

I've probably had too much coffee this morning and am misisng
somehtiong terribly obvious, as this cannot be a complicated

I'm seeing an error message after logging in and before the
gnome-session starts indicating:

"Your $HOME/.dmrc file has incorrect permissions and is being
ignored. <snip>. File should be owned by user and have 644

seems clear enough, but:

student at host$ ls -l ~/.dmrc
-rw-r--r-- 1 student student 22 Mar  21 16:35 .dmrc

another account on the system doesn't shor this error and the file is
mode 600, so I tried that and got the same error message, I also tried
deleting the file expecting gdm to recreate it, it did not recreate it
and gave the same permissions error.

The began after I chgrp'd everything in "student" to "teacher" and set
g+s on ~student/, I first tried chgrp'ing .dmrc back to student and
even took the sticky bit off the home directory.  I'm quite puzzled at
this piont...


More information about the edubuntu-devel mailing list