Solved! was Re: very bad experience installing edubuntu edgy

Gavin McCullagh gmccullagh at
Sun Dec 24 21:48:48 UTC 2006


On Wed, 20 Dec 2006, Gavin McCullagh wrote:

> having failed to install our second server with dapper some time back[1], I
> tried last night to install edgy. The server is an IBM xSeries 336.
> [1]

Having had trouble with the edgy edubuntu installer, I went back to the
Ubuntu Edgy alternate ISO image.  To my great frustration, I hit the old
software raid + ubuntu issue again with software raid and grub not being
able to boot it.  This time I had a little more time to investigate and
search around.  I came across this discussion (which to my disgust I
actually read at the time it was live):

It turns out that you should NOT put your swap partition first on the drive
as when the installer configures grub it will (in error) point it at the
swap partition, hd(0,0).  I presume this is a bug in the debian/ubuntu
installer and the only other person I can find having this issue was also
using software raid, so I guess it's specific to software raid setups and
doesn't happen to everyone who places their swap partition first on the

Rather than modify /boot/grub/menu.1st (which seems to always get
overwritten wrong with every kernel upgrade), I reinstalled.  It seems you
must completely wipe and re-create all partitions and software raid devices
or strange issues occur with the system "remembering" your previous raid
config.  Also make sure your root partition is on the FIRST raid device.

So, as advised, I then installed using the ubuntu alternate installer cd.
This has been broadly successful.  I had to run ltsp-build-client by hand
as it is not run by installation of the edubuntu-server packages.

I'm now testing sound, usb keys, etc.  All looks really well it must be
said.  More anon.


More information about the edubuntu-devel mailing list