bzr-pipeline, installers and explorer

Barry Warsaw barry at
Mon Nov 23 23:43:14 GMT 2009

On Nov 20, 2009, at 11:59 PM, Aaron Bentley wrote:

>Barry Warsaw wrote:

>> ...I've run into problems
>> where sync-pipeline fails for mostly mysterious reasons (again,
>> apologies for not having concrete examples).
>sync-pipeline expects you to use it cradle-to-grave.  If you start by
>pushing the branches with "bzr push", their pipeline relationship will
>not be preserved.  If you then use sync-pipeline, it will try to create
>the pipe that is missing from the remote branch, but since that branch
>was already pushed separately, it will be unable to create it and will die.

So, two concrete problems I've just experienced on a branch I'm trying to
finish up that I had started two weeks ago.

% bzr pipes
*  482298-picker-batching
% bzr sync-pipeline
bzr: ERROR: Not a branch: "bzr+ssh://".

I had no clue why this would be happening, since 'refactoring' doesn't show up
anywhere in any data I can find.  IOW, `bzr info` doesn't mention this and I
don't see the branch on Launchpad.

Then I remembered that two weeks ago I had worked on and landed a previous
branch where I did the same thing I did here, namely:

% cd shared-repo
% bzr co --lightweight work
% cd work
% bzr add-pipe 123456-stuff
% bzr sync-pipeline

That original sync-pipeline caused a branch lp:~barry/lazr-js/lazr-js to get
pushed that I had completely forgotten about, mostly because I didn't care
about it.  That branch I guess was stacked or somehow referenced
~barry/lazr-js/refactoring because deleting ~barry/lazr-js/lazr-js allowed me
to sync-pipeline on my current branch.

I think (please confirm) that if I had done the original co against the parent
of my local lazr-js branch, this wouldn't have happened because the lowest
pipe would have been lp:~launchpad-pqm/lazr-js/toolchain/.  If so, that'll be
a good thing to remember, but it's not the way I'm used to doing this with
looms (I know, they are not the same thing, but still, the mental model is
pretty close).

Second problem.  I wanted to link my 482298-picker-batching branch to bug
482298, so I ran the command:

bzr commit -m"fixes" --unchanged --fixes lp:482298

but then sync-pipeline linked the bottom lazr-js pipe to the bug and not the
482298-picker-batching branch.  Any idea why that was?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 835 bytes
Desc: not available
Url : 

More information about the bazaar mailing list