[RFC] Proposed plugins to bundle for 2.0
tlikonen at iki.fi
Thu Jun 25 11:20:18 BST 2009
On 2009-06-25 05:57 (-0400), John Szakmeister wrote:
> Once you understand that it's plucking your revisions and
> re-targetting to be based on a different revision, I think "rebase" as
> a command name makes quite a bit of sense. rewrite-history seems
> slightly more vague to me.
I think it's also worth noticing that this certain other popular open
source DVCS tool has already established the name "rebase" very well.
Rebasing has become a concept of its own. If the feature is called
something else in Bazaar then you'll be explaining people all the time
that "yes, Bazaar supports rebase, it's called 'bzr historiographer'
because of $philosophical_reason."
But I don't know. Maybe Bazaar invents totally different concepts for
manipulating history. Then perhaps different name for the command is fine.
More information about the bazaar