Better name for dpush wanted

Stephen J. Turnbull turnbull at
Wed Apr 29 18:14:24 BST 2009

Matthew D. Fuller writes:
 > On Wed, Apr 29, 2009 at 05:24:26PM +1000 I heard the voice of
 > Ian Clatworthy, and lo! it spake thus:
 > > 
 > > Initialisation is one concept - it ought to be one command.
 > Actually, I'd think it makes far more sense to fold init in with
 > branch than with init-repo...

It sort of makes sense, but "branch" takes a source branch and the
target must not exist, while "init" doesn't have a source, and the
target must exist.  I think the syntax of a combined branch-init
command would be very ugly in practice.

OTOH I find the whole idea of shared repositories that need explicit
initialization (and other maintenance?) confusing, and conclude that
the need for init-repo means that there's an underlying structural
problem.  Something like

bzr init                            -> initialize repo in .bzr
bzr init --shared-repo=/var/repo    -> use shared repo in /var/repo
                                       (initialize if necessary)
bzr init --shared-repo              -> use user's default shared repo,
                                       configured in ~/.bazaar
                                       (initialize if necessary)

should be workable, and if it's not, there's a problem in the design
of shared repositories.

BTW, bzr has waaaaaaay too many commands.  "bzr help commands" lists
122, and every single one is a user command whose description sounds
useful at the project workflow level.  (I have loom, bzrtools, gtk,
netrc_credential_store, rebase, and launchpad plugins installed.)

Oops, I missed at least one: bzr status is shadowed by loom's version,
and you lose all the detailed help! :-(  (Bug #369386.)

More information about the bazaar mailing list