Better name for dpush wanted

Ian Clatworthy ian.clatworthy at
Fri Apr 17 06:29:38 BST 2009

Luis Arias wrote:
> On Fri, Apr 17, 2009 at 5:51 AM, Jelmer Vernooij <jelmer at> wrote:
>> "bzr dpush" is only for users who want to push to a foreign vcs but
>> don't want to leave any references to Bazaar (e.g. bzr-related file or
>> revision properties in svn); in other words, they only want to push that
>> data that can be natively represented in the foreign vcs.
> How about npush for native push ?  I use dpush all the time and think
> of it as "diff push" or "delta push"  but "native push" seems to fit
> that logic too.

Fmom Jelmer's description of things, I'm beginning to think that the
d best stands for "dumb". So, push-dumb, push-restricted and push-brain-dead
are all possible names. :-)

Seriously, I don't mind push-native fwiw.

Ian C.

More information about the bazaar mailing list