[MERGE] repository external reference tests (StackedBranches)
v.ladeuil+lp at free.fr
Wed Jun 11 14:38:11 BST 2008
>>>>> "john" == John Arbash Meinel <john at arbash-meinel.com> writes:
john> Vincent Ladeuil wrote:
>>>>>>> "martin" == Martin Pool <mbp at canonical.com> writes:
martin> On Wed, Jun 11, 2008 at 2:35 PM, Robert Collins
martin> <robertc at robertcollins.net> wrote:
>> >> On Wed, 2008-06-11 at 13:09 +1000, Martin Pool wrote:
>> >>> At Ian's request I'm going to do these tweaks and submit it.
>> >>> I'm going to rename the module to per_repository_reference which is
>> >>> consistent with at least per_lock and much more wieldy.
>> >> Its inconsistent with all the *_implementations ones though. Can we pick
>> >> one standard and use it? I don't care which.
martin> My vote is for "per_*" then; it's shorter and imo conveys the most
martin> important information which is that they're multiplied tests.
>> +1 for the same resaons
john> Of course, now we need to decide if it is worth
john> renaming everything just for this? We certainly don't
john> have a history of large "cleanup" changes. (All of the
john> "from ... import" lines need to change, etc.)
john> As it is is the test suite, I think it is okay, though.
Whatever we decide, I think we should at least file a bug for it
and maybe add some FIXME here and there, so that a newcomer will
have a hint or two about what is the way we want things to be
done and don't get puzzled by finding several different ways in
the code base.
More information about the bazaar