bzr-svn problem: Permission denied: ".": PROPFIND request failed on '/svn/dept/ gt/trunk'

Brian de Alwis bsd at
Thu Jan 10 04:21:32 GMT 2008

Hi Jelmer.

On 9-Jan-2008, at 4:42 PM, Jelmer Vernooij wrote:
>> $ svn proplist
>> Properties on '':
>>  svn:ignore
> The PROPFIND request is used for more than just listing the properties
> on a directory. Can you try "svn ls" rather than "svn proplist" ? The
> first does ask me for a username here.

That works fine:

$ svn ls

>> Are you able to do the above 'bzr info' with your install?
> Yes, as long as I've used "svn ls" on that URL first (or, in theory,
> if I installed the Subversion 1.5 snapshot). It now fails with a
> different error though, and a very generic one that will be hard to
> debug without a network sniffer :-(

The admin sits just one room over from me, so if there's anything we  
can do to help on this end, such as sifting through logs, please just  

> What version do you mean with bleeding edge in this case?

I think I made a mistake with some paths, so I've tried this again,  
comparing Subversion 1.5 beta (r27527) and HEAD (r28840) and using bzr- 
svn 0.4.6, and Swig 1.3.27 and 1.3.31.

I've since backed out to Subversion r27527 (the 1.5 beta) and brought  
in bzr-svn 0.4.6 and using the system Python 2.5.1 and SQLite, with  
swig 2.3.27 -- and it crashes in libsvn_swig_py-1.0.dylib.  (I've  
attached the crash report below, if it matters -- I don't think it  
does.)  I have virtually identical results using swig 1.3.31!
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: crash-swig-1.3.27.txt
-------------- next part --------------

I tried against Subversion from HEAD (r28840), but 'make check-swig- 
py' produces link errors, and I get tracebacks like the following when  
trying bzr-svn:

> Traceback (most recent call last):
>   File "/Users/bsd/t/site/bzrlib/", line 203, in  
> load_from_dir
>     exec "import bzrlib.plugins.%s" % name in {}
>   File "<string>", line 1, in <module>
>   File "/Users/bsd/t/svn/", line 88, in <module>
>     check_subversion_version()
>   File "/Users/bsd/t/svn/", line 81, in  
> check_subversion_version
>     raise bzrlib.errors.BzrError("missing python subversion bindings")
> BzrError: missing python subversion bindings

Finally, just to be certain, I'm also tried installing this stuff on a  
NetBSD box just to be sure that it isn't some weirdness with MacOS X.


  Brian de Alwis | Software Practices Lab | UBC |
       "Amusement to an observing mind is study." - Benjamin Disraeli

More information about the bazaar mailing list