error on bazaar...

Alexander Belchenko bialix at
Tue Sep 11 11:08:12 BST 2007

Hash: SHA1

FW e-mail from Georgios

It was caused before I did a commit to the tree. I tried to merge and then I tried to update,... I
don't remember how I managed for this error to appear exactly I can remember the problem being that
the tree wasn't commited...

On 9/11/07, Alexander Belchenko <bialix at> wrote:

Can you explain what you did before `bzr update`?
How to reproduce this error?

Georgios Petsagourakis ?8H5B:
> bzr: ERROR: exceptions.TypeError: sequence item 1: expected string, NoneType
> fo
> nd

> Traceback (most recent call last):
>   File "bzrlib\commands.pyc", line 817, in run_bzr_catch_errors
>   File "bzrlib\commands.pyc", line 779, in run_bzr
>   File "bzrlib\commands.pyc", line 477, in run_argv_aliases
>   File "bzrlib\builtins.pyc", line 1050, in run
>   File "bzrlib\workingtree_4.pyc", line 1125, in unlock
>   File "bzrlib\workingtree_4.pyc", line 312, in flush
>   File "bzrlib\dirstate.pyc", line 1639, in save
>   File "bzrlib\dirstate.pyc", line 1224, in get_lines
>   File "bzrlib\dirstate.pyc", line 1236, in _get_parents_line
> TypeError: sequence item 1: expected string, NoneType found

> bzr 0.90.0 on python (win32)
> arguments: ['bzr', 'update']

> ** please send this report to bazaar at
> C:\Program Files\Bazaar\lib\\bzrlib\
> UserWarning: file group

> was not
> explicitly unlocked C:\Program
> Files\Bazaar\lib\\bzrlib\ UserWarning: lock on <open
> file u'C:/Kepler/1.1/web/ajato_bazaar/.bzr/checkout/dirstate', mode 'rb+' at
> 0x00F4E698> not released

- --
Best Regards,...
George Petsagourakis

Version: GnuPG v1.4.5 (MingW32)
Comment: Using GnuPG with Mozilla -


More information about the bazaar mailing list