[MERGE] Transport support for pack repositories

Martin Pool mbp at canonical.com
Thu Aug 9 05:22:14 BST 2007

Martin Pool has voted tweak.
Status is now: Conditionally approved
Please rename open_file_stream to open_write_stream or open_write or 
open_file_write_stream: something that makes it clear it's for writing.

+        A file stream is a callback which adds data to the file. 
+        may occur internally until the stream is closed with 
+        Calls to readv or the get_* methods will be synchronised with 
+        internal buffering that may be present.
+        :param relpath: The relative path to the file.
+        :param mode: The mode for the newly created file,
+                     None means just use the default
+        :return: A FileStream. FileStream objects have two methods, 
write() and
+            close(). There is no guarantee that data is committed to 
the file
+            if close() has not been called (even if get() is called on 
the same
+            path).

The return value clause comments about close() seem contradictory
with the promise above that readv and get will be synchronized.

Aside from that it's ok.

For details, see: 

More information about the bazaar mailing list