Errors branching from remote with bzr 0.0.6+20050828-0

Martin Pool martinpool at
Mon Sep 5 02:22:01 BST 2005

On 8/29/05, Kevin Smith <yarcs at> wrote:
> I was experimenting with bzr for the first time in a while, and got an
> error trying to do a branch from a remote repo. I had just done an init,
> a couple commits, and then rsync'd the entire directory to my web server.
> kevins at aria:~/work/SpaceMonkeys$ bzr branch
> verify
> bzr: ERROR: label too long
>    at /usr/lib/python2.4/encodings/ line 72, in ToASCII()
>    see ~/.bzr.log for debug information

That's a strange error.  If you still have the traceback could you post it?

> Later, I realized that this happened because my rsync script wasn't
> copying the hidden .bzr directory. After I fixed that and re-pushed, the
> branch command worked fine.
> But before I figured that out, I tried to branch from bzr itself, as
> shown in the wiki tutorial, to see if it was a problem with my repo. I
> got this error:
> kevins at aria:~/work/bzr$ bzr branch ./bzr-main
> preparing to copy
>         bzr: ERROR: 'mbp at'
>    at /usr/lib/python2.4/site-packages/bzrlib/ line 182,
> in __getitem__()
>    see ~/.bzr.log for debug information

I think this was a bug in which has since been fixed.

> Ah, which I now see is because that directory doesn't exist on
> Perhaps someone could update the tutorial to point to
> whichever bzr repo would be most appropriate.

Fixed now, thanks.  Please feel free to edit the tutorial on the wiki
if anything is unclear or insufficient.


More information about the bazaar mailing list