Misc stuff

Aaron Bentley aaron.bentley at utoronto.ca
Tue Jun 28 15:22:59 BST 2005


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

There's redundant code in the implementation of bzr pull:

        from bzrlib.branch import DivergedBranches
        br_from = find_branch(location)
        location = pull_loc(br_from)
        old_revno = br_to.revno()
        try:
            from branch import find_cached_branch, DivergedBranches
            br_from = find_cached_branch(location, cache_root, local_ref)
            location = pull_loc(br_from)
            old_revno = br_to.revno()
            try:

I think this was a bad merge.

Also, wouldn't it make sense for ImmutableStore.__getitem__ to throw
KeyError if it doesn't have an item, instead of throwing an IOError?

And can we call it something else, like FilesystemStore?  It's not
really immutable, anyway.  More like set-once.

Also, due to the restructuring, ^C no longer clears the progress bar
automatically.

Aaron
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCwV1D0F+nu1YWqI0RAl3UAJ94zoMqjCZapGOGpZSzDgRzihw/kwCcDa83
+nqrIbkKXRKV/v+JUcA+FQI=
=9pTx
-----END PGP SIGNATURE-----




More information about the bazaar mailing list