[ubuntu/zesty-proposed] mozjs38 38.2.1~rc0-0ubuntu2 (Accepted)

Jeremy Bicha jbicha at ubuntu.com
Fri Feb 17 22:39:22 UTC 2017


mozjs38 (38.2.1~rc0-0ubuntu2) zesty; urgency=medium

  * debian/control:
    - Build-Depend on libicu-dev, libreadline-dev and python-dev
  * debian/rules: Copy these build flags from Fedora:
    --with-system-icu
    --with-system-zlib
    --enable-readline
    --enable-xterm-updates
    --enable-shared-js
    --enable-gcgenerational
    --disable-optimize
    --enable-pie
  * debian/rules:
    - Also use --enable-tests but don't make tests fatal yet
    - Use --with-intl-api as recommended by gjs developer
  * Don't install .a file
  * Bump dh compat to 10 but disable autoreconf until it can be made to work
  * Drop manual -dbg packages

Date: Fri, 17 Feb 2017 17:32:04 -0500
Changed-By: Jeremy Bicha <jbicha at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/mozjs38/38.2.1~rc0-0ubuntu2
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Fri, 17 Feb 2017 17:32:04 -0500
Source: mozjs38
Binary: libmozjs-38-0 libmozjs-38-dev libmozjs-38-bin
Architecture: source
Version: 38.2.1~rc0-0ubuntu2
Distribution: zesty
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Jeremy Bicha <jbicha at ubuntu.com>
Description:
 libmozjs-38-0 - Spidermonkey JavaScript engine
 libmozjs-38-bin - Spidermonkey JavaScript shell
 libmozjs-38-dev - Spidermonkey JavaScript library - development headers
Changes:
 mozjs38 (38.2.1~rc0-0ubuntu2) zesty; urgency=medium
 .
   * debian/control:
     - Build-Depend on libicu-dev, libreadline-dev and python-dev
   * debian/rules: Copy these build flags from Fedora:
     --with-system-icu
     --with-system-zlib
     --enable-readline
     --enable-xterm-updates
     --enable-shared-js
     --enable-gcgenerational
     --disable-optimize
     --enable-pie
   * debian/rules:
     - Also use --enable-tests but don't make tests fatal yet
     - Use --with-intl-api as recommended by gjs developer
   * Don't install .a file
   * Bump dh compat to 10 but disable autoreconf until it can be made to work
   * Drop manual -dbg packages
Checksums-Sha1:
 26141d951f18d591dcf4028279a31a613dd83dd2 2165 mozjs38_38.2.1~rc0-0ubuntu2.dsc
 1134b34eeceaeb513b8e9286324733ac90ba4d91 17492 mozjs38_38.2.1~rc0-0ubuntu2.debian.tar.xz
Checksums-Sha256:
 841d8d622d73776d1319bb6de88eb768aaf6c123ef6860c3e472c3f481334a10 2165 mozjs38_38.2.1~rc0-0ubuntu2.dsc
 6ed31e9dd7c1379cc9ff16b20b587f254c7a971db219e7663721ad13276cece3 17492 mozjs38_38.2.1~rc0-0ubuntu2.debian.tar.xz
Files:
 20db9d250d5fcb0373bc34142dba94f0 2165 libs optional mozjs38_38.2.1~rc0-0ubuntu2.dsc
 ae79691ede0c9ec15e51794a3d0288f3 17492 libs optional mozjs38_38.2.1~rc0-0ubuntu2.debian.tar.xz
Original-Maintainer: Laszlo Boszormenyi (GCS) <gcs at debian.org>

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJYp3s6AAoJEOZsd1rr/mx9MyYP/jr78pHMRj11QOwkpeKtiZJO
PwfZTefAg4LVe2IMwposlaub6dAfAsvnNHj6pzfhF24j8gP+ot1V5FeSG1neOizu
DeMdD+IVlowIAt7iu1JgKlYB0jVsfy1gzOkPV3XL/Y6tnXsNkTBYeam4cNhEQdpJ
o3dowT7e8cNOIuBMpmxHX/mNGQjZZoRr/Y1uwH0AdEbN15L5f33EWA8JUXFojgiG
IMlslRQZGK+JJyXSZKaVXSxgpp6G1P1ONKHuFrxp+/3swQbwCrOVmz+t+ufDY73T
9DcO4t3NFKjarGB2SxVKUVyMquPHRCqYCXGBw2gBfx6ByRMzOLTY5mCUZmyFNFb2
Occcr/g9/FCSdgOM51ojV4WN3GdyqL6miFaXuQwrzyhDqxETgdP2A47DYh8BOjOS
q7O1iUOWzdisZNclZNv1YjLOTUBbwnQbTQgxO4Xn2spUK8MLiwbD5vW9jvtDu8uf
OcmtV62gjLInxrZ6H5HwMOdcOP5ql0ofF6GMOX6+V2D1Wz7HEg0Zjy6/zdmk6YSi
9aC6ceryH7xWJqJ+bjuZ2oeAO7K7etb72P0xCW47t3WbsJYTXcnsdwKa1viWXf0k
fsk9xWi2oh/GWRR+xeDnf/yFnoAs1l7JVzz9Wc41aUvAbq1VhH7Pah0uvAMGuMmE
1Jc8xNt51tHvSmawlDWq
=4UKm
-----END PGP SIGNATURE-----


More information about the Zesty-changes mailing list