[ubuntu/zesty-proposed] pulseaudio 1:9.0-4ubuntu1 (Accepted)

Luke Yelavich themuso at ubuntu.com
Fri Oct 28 01:29:16 UTC 2016


pulseaudio (1:9.0-4ubuntu1) zesty; urgency=medium

  * Merge with Debian:
    - epoch (my stupid fault :S)
    - Add a module to allow pulseaudio to use the Android audio HAL
    - Adjust gbp.conf file to point to the ubuntu branch for package builds
    - Disable module-role-cork by default
    - Load module-x11-bell in the start-pulseaudio-x11 script
    - Hide pulseaudio from startup apps dialog
    - Quit daemon if pid file is removed
    - Avoid abort when poll descriptor is 0, such as when using it with the
      audioflinger bridge, like done in ubuntu touch
    - change default rlimit_rttime value to 200 ms
    - Don't probe UCM profiles, trust that the profile writer knows what they
      are doing
    - Add card hook to allow modules to do something before a profile becomes
      active
    - Add an option to the bluez discovery module to set the profile
    - Allow leaving bluetooth transport running while sink and source are
      suspended.
    - Add option to module-switch-on-connect to skip abstract devices
    - Add property to module-device-restore to skip store/restore
    - Add missing fields for sink_input/source_output info struct to the vala
      bindings
    - Add a build/run autopkgtest for libpulse-dev
    - Drop libsoxr-dev build dep, its in universe
    - Add support for the trust-store
    - Add snappy support, preventing snap apps from recording audio, full
      support via trust-store is planned
    - Use conflicts/replaces instead of breaks to handle former
      pulseaudio-module-udev split
  * 0502-bluetooth-bluez5-bring-back-SCO-over-PCM-support.patch:
    - Remove patch hunk that set u->transport to NULL. At the time this
      code was written for 15.10, it was to prevent an assertion. Now with
      newer versions of pulse, the opposite is happening in some circumstances
      (LP: #1574324)
  * debian/control: Use liblirc-dev instead of liblircclient-dev

pulseaudio (9.0-4) unstable; urgency=medium

  * Generate shlibs.local file on build, to avoid hardcoding
    on each new upstream version
  * Enable hardening flags
  * Fix build on nonlinux archs

pulseaudio (9.0-3) unstable; urgency=medium

  [ Willem Mulder ]
  * Split equalizer sink module into its own package (Closes: #794650)

  [ Felipe Sateler ]
  * Switch from CDBS to short-form dh
  * Use upstream-provided pamon,parec,parecord links instead of creating our own
  * Now that we ship everything upstream ships, enable --fail-missing

Date: Fri, 28 Oct 2016 12:20:16 +1100
Changed-By: Luke Yelavich <themuso at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/pulseaudio/1:9.0-4ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 28 Oct 2016 12:20:16 +1100
Source: pulseaudio
Binary: pulseaudio pulseaudio-utils pulseaudio-esound-compat pulseaudio-module-zeroconf pulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-gconf pulseaudio-module-raop pulseaudio-module-droid pulseaudio-module-trust-store pulseaudio-module-bluetooth pulseaudio-equalizer libpulse0 libpulse-mainloop-glib0 libpulse-dev libpulsedsp
Architecture: source
Version: 1:9.0-4ubuntu1
Distribution: zesty
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Luke Yelavich <themuso at ubuntu.com>
Description:
 libpulse-dev - PulseAudio client development headers and libraries
 libpulse-mainloop-glib0 - PulseAudio client libraries (glib support)
 libpulse0  - PulseAudio client libraries
 libpulsedsp - PulseAudio OSS pre-load library
 pulseaudio - PulseAudio sound server
 pulseaudio-equalizer - Equalizer sink module for PulseAudio sound server
 pulseaudio-esound-compat - PulseAudio ESD compatibility layer
 pulseaudio-module-bluetooth - Bluetooth module for PulseAudio sound server
 pulseaudio-module-droid - Android Audio HAL module for PulseAudio sound server
 pulseaudio-module-gconf - GConf module for PulseAudio sound server
 pulseaudio-module-jack - jackd modules for PulseAudio sound server
 pulseaudio-module-lirc - lirc module for PulseAudio sound server
 pulseaudio-module-raop - RAOP module for PulseAudio sound server
 pulseaudio-module-trust-store - trust-store module for PulseAudio sound server
 pulseaudio-module-zeroconf - Zeroconf module for PulseAudio sound server
 pulseaudio-utils - Command line tools for the PulseAudio sound server
Closes: 794650
Launchpad-Bugs-Fixed: 1574324
Changes:
 pulseaudio (1:9.0-4ubuntu1) zesty; urgency=medium
 .
   * Merge with Debian:
     - epoch (my stupid fault :S)
     - Add a module to allow pulseaudio to use the Android audio HAL
     - Adjust gbp.conf file to point to the ubuntu branch for package builds
     - Disable module-role-cork by default
     - Load module-x11-bell in the start-pulseaudio-x11 script
     - Hide pulseaudio from startup apps dialog
     - Quit daemon if pid file is removed
     - Avoid abort when poll descriptor is 0, such as when using it with the
       audioflinger bridge, like done in ubuntu touch
     - change default rlimit_rttime value to 200 ms
     - Don't probe UCM profiles, trust that the profile writer knows what they
       are doing
     - Add card hook to allow modules to do something before a profile becomes
       active
     - Add an option to the bluez discovery module to set the profile
     - Allow leaving bluetooth transport running while sink and source are
       suspended.
     - Add option to module-switch-on-connect to skip abstract devices
     - Add property to module-device-restore to skip store/restore
     - Add missing fields for sink_input/source_output info struct to the vala
       bindings
     - Add a build/run autopkgtest for libpulse-dev
     - Drop libsoxr-dev build dep, its in universe
     - Add support for the trust-store
     - Add snappy support, preventing snap apps from recording audio, full
       support via trust-store is planned
     - Use conflicts/replaces instead of breaks to handle former
       pulseaudio-module-udev split
   * 0502-bluetooth-bluez5-bring-back-SCO-over-PCM-support.patch:
     - Remove patch hunk that set u->transport to NULL. At the time this
       code was written for 15.10, it was to prevent an assertion. Now with
       newer versions of pulse, the opposite is happening in some circumstances
       (LP: #1574324)
   * debian/control: Use liblirc-dev instead of liblircclient-dev
 .
 pulseaudio (9.0-4) unstable; urgency=medium
 .
   * Generate shlibs.local file on build, to avoid hardcoding
     on each new upstream version
   * Enable hardening flags
   * Fix build on nonlinux archs
 .
 pulseaudio (9.0-3) unstable; urgency=medium
 .
   [ Willem Mulder ]
   * Split equalizer sink module into its own package (Closes: #794650)
 .
   [ Felipe Sateler ]
   * Switch from CDBS to short-form dh
   * Use upstream-provided pamon,parec,parecord links instead of creating our own
   * Now that we ship everything upstream ships, enable --fail-missing
Checksums-Sha1:
 5719cdccb4b44510834b587fcf4d0cd40b8f386a 3704 pulseaudio_9.0-4ubuntu1.dsc
 867031343d453c12bf596bd9bec9d588bbb6a32d 140800 pulseaudio_9.0-4ubuntu1.debian.tar.xz
Checksums-Sha256:
 213b27859def16d3e710602b7a40774ad0b2c2b2e02c50888f7e74cab25edcbc 3704 pulseaudio_9.0-4ubuntu1.dsc
 980d88c68d1bbd1dbade11f3934d4bd4acd1c3d6906b4eeb96d047d66356b07d 140800 pulseaudio_9.0-4ubuntu1.debian.tar.xz
Files:
 67674f2c99e2da10dfce9ca5783869df 3704 sound optional pulseaudio_9.0-4ubuntu1.dsc
 06be5acf68a955d567d613db953b89a1 140800 sound optional pulseaudio_9.0-4ubuntu1.debian.tar.xz
Original-Maintainer: Pulseaudio maintenance team <pkg-pulseaudio-devel at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----

iFoEARECABoFAlgSqcYTHHRoZW11c29AdWJ1bnR1LmNvbQAKCRCNV5/C0GMgzgkI
AJwJWGB0SNtir84JAhXCRJ1JF8YcxQCg4oTdD778kp7ddMNVVsaGMqvTjQc=
=CY5O
-----END PGP SIGNATURE-----


More information about the Zesty-changes mailing list