[ubuntu/yakkety-updates] poppler 0.44.0-3ubuntu2.1 (Accepted)

Ubuntu Archive Robot cjwatson+ubuntu-archive-robot at chiark.greenend.org.uk
Fri Jul 7 14:58:18 UTC 2017


poppler (0.44.0-3ubuntu2.1) yakkety-security; urgency=medium

  * SECURITY UPDATE: NULL pointer dereference in pdfunite
    - debian/patches/CVE-2017-7511.patch: add extra checks to
      utils/pdfunite.cc.
    - CVE-2017-7511
  * SECURITY UPDATE: uncontrolled recursion in pdfunite
    - debian/patches/CVE-2017-7515.patch: fix recursion in
      poppler/PDFDoc.cc, poppler/PDFDoc.h.
    - CVE-2017-7515
  * SECURITY UPDATE: NULL pointer dereference in JPXStream::readUByte
    - debian/patches/CVE-2017-9083.patch: check nComps in
      poppler/JPXStream.cc.
    - CVE-2017-9083
  * SECURITY UPDATE: memory leak in gmalloc
    - debian/patches/CVE-2017-9406.patch: fix leak in poppler/XRef.cc.
    - CVE-2017-9406
  * SECURITY UPDATE: memory leak in Object::initArray
    - debian/patches/CVE-2017-9408.patch: fix leak in poppler/XRef.cc.
    - CVE-2017-9408
  * SECURITY UPDATE: stack buffer overflow in GfxState.cc
    - debian/patches/CVE-2017-9775.patch: add extra checks to
      poppler/GfxState.cc.
    - CVE-2017-9775
  * SECURITY UPDATE: integer overflow in JPXStream::readTilePart
    - debian/patches/CVE-2017-2820.patch: check for overflow in
      poppler/JPXStream.cc.
    - CVE-2017-2820

Date: 2017-07-06 17:38:30.354992+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
Signed-By: Ubuntu Archive Robot <cjwatson+ubuntu-archive-robot at chiark.greenend.org.uk>
https://launchpad.net/ubuntu/+source/poppler/0.44.0-3ubuntu2.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Yakkety-changes mailing list