[ubuntu/yakkety-security] gtk-vnc 0.6.0-1ubuntu1.1 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Mon Feb 20 15:25:19 UTC 2017


gtk-vnc (0.6.0-1ubuntu1.1) yakkety-security; urgency=medium

  * SECURITY UPDATE: insufficient bounds checking
    - debian/patches/CVE-2017-5884.patch: add checks to
      src/vncconnection.c, add test to cfg.mk, src/Makefile.am,
      src/vncconnectiontest.c.
    - CVE-2017-5884
  * SECURITY UPDATE: integer overflow when processing SetColorMapEntries
    - debian/patches/CVE-2017-5885-1.patch: don't accept color map entries
      for true-color pixel format in src/vncconnection.c, add test to
      src/vncconnectiontest.c.
    - debian/patches/CVE-2017-5885-2.patch: correctly validate color map
      range indexes in src/vnccolormap.c, src/vncconnection.c, add test to
      src/vncconnectiontest.c.
    - CVE-2017-5885

Date: 2017-02-17 19:07:25.248933+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/gtk-vnc/0.6.0-1ubuntu1.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Yakkety-changes mailing list