[xubuntu-users] shell tools

pereira ninorpereira at gmail.com
Sun Jan 8 19:12:41 UTC 2017

On 01/08/2017 12:06 PM, Ulli Horlacher wrote:
> On Sun 2017-01-08 (11:22), pereira wrote:
>> Trying to learn some more, I tried sudo apt get install sw,
>> and sudo apt-get install swtools, but nothing useful happend.
> /sw is a UNIX software distribution system developed at the University of
> Stuttgart, long before Linux existed!
> You cannot install it with apt, because /sw is not an application, but a
> software distribution system!
> Part of /sw are my fstools.
> Using of /sw is not mandatory, it is just easier to do so, because of the
> updater, etc.
> You can download fstools or part of them manually from
> http://fex.belwue.de/fstools/
I did this with the command given below the list  of fstools, viz.,

get -O- http://fex.belwue.de/sw/share/fstools-0.0.tar | tar xvf -

This worked without problem, except that the executables ended up in a 
directory fstools-0.0/bin, so that an additional step is necessary to 
get them to
work without having to jump through hoops. By now I know enough about linux
to know which hoops those are, but a few years ago I would have been 
and would have had to spend a lot of time to find out what to do. Most 
likely I
would have given up.

So, an additional piece of information ($PATH... bla-bla) would have 
helped here.

Better yet would be to package fstools as something that installs them 
the newfangled
debian/unix way with apt-get; I certainly don't know how to do it with 
the more
venerable sw.



More information about the xubuntu-users mailing list