[xubuntu-users] toggle touchpad ON/OFF

fred roller fredroller66 at gmail.com
Thu Mar 31 08:20:09 UTC 2016

While working on this script part have you tried

Programs --> Settings --? Mouse and Touchpad --> Touchpad (tab)

and check the "Disable touchpad while typing" option.

That aside... sounds like the script, xinput.." command needs to query the
device id so that it grows with the OS.

Lastly, perhaps the word struggling should be changed out with
contributing.  You are correct that easier methods should be available for
many little tweaks and tricks used in any OS.  As a community, we are the
R&D department for Linux.  You are doing well to stick with it and your
efforts are appreciated.

On Thu, Mar 31, 2016 at 2:27 AM, Thomas Blasejewicz <nyuwa at hb.tp1.jp> wrote:

> On 2016/03/30 4:09, Steve Litt wrote:
>> On Wed, 30 Mar 2016 02:22:04 +0900
>> Thomas <nyuwa at hb.tp1.jp> wrote:
>> On 2016年03月28日 07:49, Steve Litt wrote:
>>>> On Sun, 27 Mar 2016 19:06:57 +0900
>>>> Thomas <nyuwa at hb.tp1.jp> wrote:
>>>> #!/bin/bash
>>>> curstate=`synclient | grep -i TouchpadOff | sed -e"s/.*= //"`
>>>> if test "$curstate" = "1"; then
>>>> synclient TouchpadOff=0
>>>> else
>>>> synclient TouchpadOff=1
>>>> fi
>>>> What you have left now is just some troubleshooting. Start by seeing if
>>>> the command works without a hotkey, by typing the word touchtoggle
>>>> followed by the Enter key at the command prompt, and seeing whether it
>>>> turns on and off the touchpad. Make sure the touchtoggle file is
>>>> permissioned as executable by all. If it's permissioned executable for
>>>> all and still doesn't toggle the touchpad state, you need to start
>>>> experimenting with the individual "synclient TouchpadOff=0" and
>>>> "synclient TouchpadOff=1" commands at the command prompt.
>>> I tried running "synclient TouchpadOff=0" in a terminal.
> That gives me the error message:
> "Couldn't find synaptics properties. No synaptics driver loaded?"
> Using Package Manager I looked for "synclient". There was ONE package
> installed
> and I added the only other apparently related package
> (xserver-xorg-input-synaptics dbg 1.8.2-ubuntu1)
> That did not change anything.
> Somebody else previously suggested using the commands:
> "xinput set-prop 14 "Device Enabled" 0 (to disable and 1 to enable)"
> THAT command actually works.
> Device ID: here "14".
> A few days ago I tried to "update" my system, made a mistake somewhere and
> ended up with an "upgrade" to 15.10.
> (lots of trouble with that one too)
> BEFORE the upgrade the same device had the ID "12". AFTER the upgrade the
> same device suddenly has the ID "14".
> With the above command I am supposed to create a ".desktop" file under
> /usr/local/share/applications/
> (have not yet figured out how to do that)
> and then create a shortcut (hotkey) to that file.
> This sounds like a real pain in the posterior,
> Indeed. There REALLY should be something more easy to accomplish this
> everyday task.
>> but the more you do this
>> kind of troubleshooting, the more proficient you get, until, one day in
>> the near future, people start saying "Go to Thomas, he can fix
>> anything."
>> Thank you for your kind words. Apparently I am not doing very well.
> I am struggling to "get friendly" with Linux for about 8 years with rather
> little success.
> The posts here make that clear I think.
> Thomas
> --
> xubuntu-users mailing list
> xubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/xubuntu-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20160331/1f8033e4/attachment.html>

More information about the xubuntu-users mailing list