[xubuntu-users] Two printers available in programs but only one is installed

Petter Adsen petter at synth.no
Mon Feb 22 10:46:18 UTC 2016


On Mon, 22 Feb 2016 10:29:32 +0000
Chris Green <cl at isbd.net> wrote:

> On Mon, Feb 22, 2016 at 11:05:19AM +0100, Petter Adsen wrote:
> > On Mon, 22 Feb 2016 09:57:02 +0000
> > Chris Green <cl at isbd.net> wrote:
> >   
> > > ... and I've found what produces it, thought it's still a bug.
> > > For some reason the presence of the printer on the LAN is what
> > > creates these 'phantom' printers.  If I power the printer down
> > > both the OKI-MC342-AE529C in Firefox and the 'print' in AbiWord
> > > disappear.
> > > 
> > > So their print option seems to somehow 'see' the network printer
> > > and thinks it can be used.  As I said early on LibreOffice does
> > > things right and doesn't see this phantom printer.  
> > 
> > Is cups-browsed installed?
> >   
> Yes.

Disable or uninstall it. If you do 'apt show cups-browsed' you can see
why that would probably help.

Try 'sudo systemctl stop cups-browsed.service' first. If that stops the
extra printer queue from showing up, then you can stop it from starting
up again at the next boot with 'sudo systemctl disable
cups-browsed.service'.

Other alternatives:

1. Set 'CreateIPPPrinterQueues' to 'No' in /etc/cups/cups-browsed.conf
2. Set 'BrowseRemoteProtocols' to 'none' or 'cups' in the same file
3. Set 'BrowseAllow' to a range that excludes the printer, also in the
   same file.

I think either of these would solve the issue.

Petter

-- 
"I'm ionized"
"Are you sure?"
"I'm positive."




More information about the xubuntu-users mailing list