[xubuntu-users] Further to "Mouse focus problem in 15.10"

Chris Green cl at isbd.net
Sat Feb 20 15:32:03 UTC 2016

On Thu, Feb 18, 2016 at 05:00:22PM +0100, Petter Adsen wrote:
> On Thu, 18 Feb 2016 14:56:34 +0000
> Chris Green <cl at isbd.net> wrote:
> > I've been digging around this for a while now!
> > 
> > I took my laptop apart a bit and vacuumed out the keyboard and
> > touchpad switches etc.  There didn't seem to be a lot of dirt there
> > though.
> > 
> > Since then I have discovered that if I disable the TPPS/2 IBM
> > Trackpoint then all problems disappear, but the Trackpoint stops
> > working of course.  Since that includes the very handy middle button 2
> > it's not a good solution.
> > 
> > This looks like it's a problem caused by a recent update to something
> > as until recently everything worked perfectly.  It's only a few days
> > ago that things started going awry.
> > 
> > Can anyone suggest what update might have affected things?
> My WAG would be one of the recent kernel updates, which is easy enough
> to test. You should still have one previous kernel, try rebooting into
> that and see if it helps. If it doesn't, install the version before
> that and so on. See the apt-get man page on how to install specific
> versions of packages.
> If older kernels don't help, go through your apt logs and look for
> anything that might be involved, like the X server.
> Be careful when downgrading packages, as it's not usually recommended
> to do so. I'd suggest a full backup before starting.
Well I've proved it's definitely a bug.  I've just installed gpm the
mouse handler for the console.  When the problem happens in X I can
switch to a console (CTRL/ALT/Fn) and the buttons still work fine with
gpm.  In addition doing this clears the problem in X.

I've tried two older kernels, the bug is still there.  How can I check
to see when other packages have been changed?

Using xev to check button events what happens when the bug occurs is
that there is a single button 3 event (no release) and after that
neither button 2 nor button 3 produce any events.

Chris Green

More information about the xubuntu-users mailing list