[xubuntu-users] vlc segmentation fault - core dump

Fred Roller fredroller66 at gmail.com
Fri May 16 18:40:00 UTC 2014


Hello all, on 14.04 vlc is refusing to start.  When run from cli I get a 
segmentation fault error. when run with the -vv option I get this error 
just before the core dump.

[snip]
[0x118a728] skins2 interface debug: number of monitors detected : 2
[0x118a728] skins2 interface debug:   monitor #0 : 1360x768 at +1440+0
[0x118a728] skins2 interface debug:   monitor #1 : 1440x900 at +0+0
[0x118a728] skins2 interface debug: cannot open directory 
/home/froller/.local/share/vlc/skins2
[0x118a728] skins2 interface debug: cannot open directory share/skins2
[0x118a728] skins2 interface debug: found skin 
/usr/share/vlc/skins2/default.vlt
[0x118a728] skins2 interface debug: requested skins  is NOT accessible
[0x7f3364028978] main generic debug: looking for dialogs provider module 
matching "any": 1 candidates
[0x7f3364028978] main generic debug: using dialogs provider module "qt4"
Segmentation fault (core dumped)

I have purged vlc, twice.  The second time I rm -rf .local/share/vlc 
/usr/share/vlc /usr/lib/vlc then re-installed.  Still the above error.

vlc worked on my system about a week ago until I changed from default 
look to the skin which came with it, just trying something new.  vlc 
didn't work right so I changed it back to default and it worked. I think 
vlc received an update since then so I can't pin point any probable 
cause precisely.

My system is an Acer Travelmate 7520 AMD 64.  I am venturing a guess 
there is a permission issue with the referenced files above so will 
pursue that avenue when I get back from work.  If anyone has some 
insight or direction it would be appreciated.  Search has not found 
anything useful yet but will continue to search later tonight.

- Fred




More information about the xubuntu-users mailing list