[xubuntu-users] Synaptic doesn't work on a new 14.04 installation

Chris Green cl at isbd.net
Sat Jul 19 10:15:55 UTC 2014


On Fri, Jul 18, 2014 at 01:43:03PM -0400, Steve Litt wrote:
> On Thu, 17 Jul 2014 16:13:10 +0100
> Chris Green <cl at isbd.net> wrote:
> 
> > I have just installed xubuntu 14.04 on an IBM Thinkpad x201i.
> > 
> > I like to use synaptic for adding software so I installed that (from
> > the command line using apt-get) but it doesn't work, there are various
> > symptoms according to how you try to run it:-
> > 
> >     Run from the menus - asks for authentication in the normal manner
> >     but nothing further happens, no GUI, nothing.
> > 
> >     Run from the command line as ordinary user - synpatic GUI comes up
> >     OK but of course with the message that you can't actually install
> >     anything as you don't have root privilege.
> > 
> >     Run 'sudo synaptic' and you get the following errors after
> >     entering the password:-
> > 
> >         No protocol specified
> >         **[synaptic:10781]: WARNING **: Could not open X display
> >         No protocol specified
> >         error: XDG_RUNTIME_DIR not set in environment.
> >         **[synaptic:10781]: Gtk-WARNING **: cannot open display: :0.0
> > 
> > 
> > Wierdly enough if I 'ssh -X ...' into the system from another computer
> > on the LAN I *can* run synaptic successfully!
> 
> What happens if you do the following:
> 
> 1) Run an xterm (or aterm or rxvt if you don't have xterm)
> 
> 2) On the xterm, run su -c
> 
I don't think that's right, "su -c" just means run a command so it
returns an error.

> 3) On the su root xterm, run synaptic
> 
> SteveT
> 
> Steve Litt                *  http://www.troubleshooters.com/
> Troubleshooting Training  *  Human Performance
> 
> 
> -- 
> xubuntu-users mailing list
> xubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/xubuntu-users

-- 
Chris Green




More information about the xubuntu-users mailing list