[xubuntu-users] Another problem with 14.04 - printers

MR ZenWiz mrzenwiz at gmail.com
Mon Aug 25 07:59:58 UTC 2014


I just configured my printer, a USB Brother HL-2240D, to be the system
default, but for some reason the printer settings window can't seem to
get a test page printed.  lpstat -t shows that the system is "Sending
data to the printer" but nothing ever prints:

$ lpstat -t
scheduler is running
system default destination: Brother-HL-2240D-series
device for Brother-HL-2240D-series:
usb://Brother/HL-2240D%20series?serial=G1N406058
Brother-HL-2240D-series accepting requests since Mon 25 Aug 2014 12:53:05 AM PDT
printer Brother-HL-2240D-series is idle.  enabled since Mon 25 Aug
2014 12:53:05 AM PDT
Sending data to printer.

CUPS can't make any progress with it either.

/var/log/cups/error_log shows this:

E [25/Aug/2014:00:44:26 -0700] Brother-HL-2240D-series: File
"/usr/lib/cups/filter/brlpdwrapperHL2240D" not available: No such file
or directory
E [25/Aug/2014:00:44:26 -0700] Brother-HL-2240D-series: File
"/usr/lib/cups/filter/brlpdwrapperHL2240D" not available: No such file
or directory
E [25/Aug/2014:00:44:26 -0700] Brother-HL-2240D-series: File
"/usr/lib/cups/filter/brlpdwrapperHL2240D" not available: No such file
or directory
E [25/Aug/2014:00:51:37 -0700] [Client 7] Request for non-absolute resource "".
E [25/Aug/2014:00:51:37 -0700] [Client 7] Request for non-absolute resource "".
W [25/Aug/2014:00:51:37 -0700] CreateProfile failed:
org.freedesktop.ColorManager.AlreadyExists:profile id
'Brother-HL-2240D-series-Gray..' already exists

I fixed the missing file problem, but it still won't print.  I'm not
sure what the last three lines mean.

I need to be able to print with this thing, and my other printer
(which I rarely even turn on, but still...).

What am I missing?

Thanks.
MR




More information about the xubuntu-users mailing list