[xubuntu-users] cannot install fritzing electronics package on 14.04

Paul Sutton zleap at zleap.net
Sun Aug 17 17:56:26 UTC 2014


Hi

I am trying and failing to install the fritzing electronics package on
xubuntu 14.04

have followed instructions here

http://software.opensuse.org/download.html?project=home:Heinervdm:branches:Education&package=fritzing

so

sudo sh -c "echo 'deb
http://download.opensuse.org/repositories/home:/Heinervdm:/branches:/Education/xUbuntu_14.04/
/' >> /etc/apt/sources.list.d/fritzing.list"
sudo apt-get update
sudo apt-get install fritzing

and also carried out this step

wget
http://download.opensuse.org/repositories/home:Heinervdm:branches:Education/xUbuntu_14.04/Release.key
sudo apt-key add - < Release.key

if I do the above	

I get the following output

psutton at ER1401:~$ sudo apt-get install fritzing
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  fritzing
1 to upgrade, 0 to newly install, 0 to remove and 42 not to upgrade.
1 not fully installed or removed.
Need to get 0 B/16.1 MB of archives.
After this operation, 130 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  fritzing
Install these packages without verification? [y/N] y
(Reading database ... 328644 files and directories currently installed.)
Preparing to unpack .../fritzing_0.9.0b_i386.deb ...
Unpacking fritzing (0.9.0b) over (0.8.5b+dfsg-1) ...
dpkg: error processing archive
/var/cache/apt/archives/fritzing_0.9.0b_i386.deb (--unpack):
 trying to overwrite '/usr/share/fritzing/sketches/index.xml', which is
also in package fritzing-data 0.8.5b+dfsg-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/fritzing_0.9.0b_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)




This is after multiple attempts,  first ly I tried to just do sudo
apt-get install fritzing fritzing-data and it seemed to go through fine
but was unable to find it on the menu,  logged out and logged back in
and nothing onthe menu, so tried the steps above after googling.

I am sure this worked when i was using lubuntu though.

if it helps output of inxi

CPU~Dual core AMD Athlon II Neo K325 (-MCP-) clocked at Min:800.000Mhz
Max:1100.000Mhz Kernel~3.13.0-30-generic i686 Up~6:52 Mem~787.9/1761.9MB
HDD~250.1GB(35.8% used) Procs~176 Client~Shell inxi~1.9.17
psutton at ER1401:~$


and

psutton at ER1401:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.1 LTS
Release:	14.04
Codename:	trusty

can someone help please,  thanks


Paul


-- 
http://www.zleap.net
@zleap14
Torbay Raspberry Pi jam info - http://www.dcglug.org.uk/

I am committed to safeguarding children, young people and
vulnerable groups and expect any school, establishment or organsation that
I am involved with to share this commitment.




More information about the xubuntu-users mailing list