[xubuntu-users] Webcam support

Peter Flynn peter at silmaril.ie
Sat Feb 2 22:58:13 UTC 2013


I recently upgraded all my machines to Xubuntu 12.10 and generally 
things have been excellent. I now need some help out of my ignorance.

http://linux-kerala.blogspot.ie/2011/01/how-i-got-my-webcam-working-in-linux.html 
describes exactly what I have; but cheese crashes.

My USB webcam (a cheapo €12 bought at Tesco 3 years ago) worked 
perfectly under regular Ubuntu up to 10.04 but hasn't worked since.
dmesg reports:

> [30091.808020] usb 3-2: new full-speed USB device number 3 using uhci_hcd
> [30092.036949] usb 3-2: New USB device found, idVendor=093a, idProduct=2468
> [30092.036956] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
> [30092.036960] usb 3-2: Product: CIF Single Chip
> [30092.036964] usb 3-2: Manufacturer: Pixart Imaging Inc.
> [30092.260084] Linux video capture interface: v2.00
> [30092.279758] gspca_main: v2.14.0 registered
> [30092.281823] gspca_main: pac207-2.14.0 probing 093a:2468
> [30092.288427] input: pac207 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/input/input4
> [30092.289003] usbcore: registered new interface driver pac207

peter at adam:~$ ls -l /dev/vid*
crw-rw----+ 1 root video 81, 0 Feb  2 22:18 /dev/video0
peter at adam:~$ lsusb
Bus 002 Device 002: ID 03f0:2612 Hewlett-Packard
Bus 003 Device 002: ID 046d:c00c Logitech, Inc. Optical Wheel Mouse
Bus 003 Device 004: ID 093a:2468 Pixart Imaging, Inc. SoC PC-Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
peter at adam:~$ lsmod | grep videodev
videodev               95842  2 gspca_pac207,gspca_main

camorama and kamerka both show the image OK, if a little slow.
vlc v4l2:///dev/video0 shows the image OK.
GUVCview also works, but it says it can only get 1 frame per second :-)

cheese crashes instantly on launch.
Flash web chat apps all detect no camera.
https://www.mozilla.org/en-US/plugincheck/ confirms I have the latest
    version of the Flash plugin installed.
Skype config detects CIF Single Chip but shows no image.
Google Talk plugin detects "gspca main driver" but shows no image.
Empathy config goes to Languages, Printers, and Software Sources (!)
Pidgin doesn't appear to have a video option.

I'm happy to buy a new webcam if need be, but I'd want a copper-bottomed 
assurance that it will work in Xubuntu 12.10. I'm just curious to see if 
the existing one could be made to work in Skype and Flash.

///Peter






More information about the xubuntu-users mailing list