[xubuntu-users] Trying to get Broadcom Wifi working

Steven Grace sgrace at pobox.com
Sat Aug 3 00:26:30 UTC 2013


On 08/02/2013 12:38 PM, Lee Gold wrote:

> I have an HP Pavillion dv6000 it has a Broadcom BM4311 chip for WiFi.
> Wifi doesn't work.
>
> I tried running:
>
> sudo apt-get install bcmwl-kernel-source
>
> But there seems to be a problem. I run it and it finally says "DKMS:
> Install Completed" but just hangs at that point and the command prompt
> never comes back. I do control-c. Every time I boot to recovery mode and
> do repair pakages it says something is wrong and goes through this
> instsall process and again ends with DKMS: Install Completed" just
> hangs.
>
> It doesn't seem like the command is fully executing. I wait for a long
> time. Soemthing seems wrong - not sure.
>
> Any suggestions appreciated. Using Xubuntu 12.04

I have a Pavilion g7, also running Xubuntu 12.04. It uses a Broadcom 
WiFi chipset, although I don't recall if it's the same as yours. I was 
able to get WiFi working by installing the proprietary driver 
(Applications > Settings > Additional Drivers). If you have that option 
it's easier than installing from source.





More information about the xubuntu-users mailing list