[xubuntu-users] How can a custom-mounted drive show on desktop as mounted

dg1727 dg1727 at hushmail.com
Wed Sep 12 15:27:11 UTC 2012


Hello, 

I have posted this on the xfce AT xfce DOT org mailing list, and 
not gotten an answer yet, so maybe someone on this list has a 
suggestion:  

On Xubuntu 12.04.1, I have written a "udev" rule that calls a
custom shell script to mount a USB ext4fs drive with custom mount
options.  The drive gets mounted correctly so that the "mount"
command shows the drive and the correct options.  On the XFCE
desktop, however, the drive icon is grayed out, and the icon's
right-click menu has an option for "Mount Volume." 

Is there a way to have XFCE update the icon automatically, as soon
as the USB drive is inserted, to show that the volume is already
mounted? 

I have tried: 

thunar-volman --device-added /sys$DEVPATH

where $DEVPATH is the sysfs path of the newly added device.  This
command doesn't seem to do anything, including when I run the
command in a terminal window (even with superuser privileges). 

Installed versions include xfdesktop 4.8.3, thunar-volman 0.6.1

Thanks for any insight, including if I have missed something
obvious.  

-dg1727





More information about the xubuntu-users mailing list