[xubuntu-users] Libre Office spell check

Neil Winchurst neilwin at drofle.co.uk
Sat Jul 21 08:08:35 UTC 2012


On 21/07/12 00:53, Atherton wrote:
> On 21/07/12 03:24, Jack Evans wrote:
>> On 20/07/12 17:47, Neil Winchurst wrote:
>>> I have noticed that the spell check in Libre Office is not working
>>> properly. This is in Xubuntu 12.04. Is this a known problem or is it
>>> something that I have done?
>>>
>>> Thanks
>>>
>>> Neil
>>>
>> It should work by default, check you have the correct SpellChecker
>> Installed, go to Tools >> Options >> Language Settings >> Writing Aids >>
>>
>> In there you should have a Spell Checker enabled in a check box, for
>> me it's "Hunspell SpellChecker"
>>
>> under options make sure you have Check Spelling/ Check Grammar as you
>> type checked
>>
> I also had problems after I downloaded and installed a British English
> dictionary from Libre Office
> [KPP-british-english-dictioonary-217K-word-list.oxt]. The default
> dictionary in LibreOffice appears to be US English. After this
> installation, trying to use a UK dictionary to 'correct' US spelling [eg
> -or/-our and -ise/-ize words] resulted in every word being underlined as
> incorrect and gave weird suggestions for simple words like "the".  Fixed
> problem by going to Settings - Language Support in Xubuntu and using
> Language - Install/Remove languages [there is a help file] - ended up
> with Australian -British - and US English dictionaries that I could use.
> (Don't know where these came from). Set English (Australia) as default
> Western language for documents in Tools > Options > Language Settings >
> Languages, and, in Writing Aids clicked Edit for Available Language
> modules and set English (Australia) as preferred language for Spelling.
> As I remember in also became the default for Hunspell Spellchecker,
> Grammar, Hyphenation, Thesaurus and OpenOffice.org New Thesaurus.
> 
> Atherton
> 
Thanks to both. This is on my daughter's new laptop which I have just
bought her for her birthday, so I will check all this when I can. The
symptoms are,

I have set it up to check spelling as I type. It doesn't. If I press F7
to force a check I get a window up looking like a normal spell check
winkdow. Superimposed on that is a smaller message window saying that
the spell check is complete. It hasn't actually checked anything.

Thanks

Neil




More information about the xubuntu-users mailing list