[xubuntu-users] ATI Binary Driver problem (was: Xscreensaver oddity)

Pete Flugstad pete.flugstad at gmail.com
Sat Jul 14 15:38:09 UTC 2012


Pete Flugstad <pete.flugstad at ...> writes:
> OK - time to figure out if the open source driver is functional. 

So - I installed the xorg-edgers/ppa
(https://launchpad.net/~xorg-edgers/+archive/ppa) and made sure
 I installed the -ati driver (xserver-xorg-video-ati).

Note that the -ati driver seems to just be a wrapper around the 
radeon driver (xserver-xorg-video-radeon), but if I installed 
*just* the radeon driver, Xorg would not find it and it'd fall 
back to vesa again.  Once I did that, I didn't need a 
/etc/X11/xorg.conf at all - Xorg just auto-configured itself. 

So - this seems to have fixed my problems.  Xscreensaver comes up
every time, I can switch sessions with no trouble, etc.  No 
lockups with multiple users and the screen saver seems to get
disabled properly.  So far anyway.

Performance wise, I don't see any difference.  I don't do 
heavy-duty gaming, so I probably wouldn't.   

I don't know if I actually need the xorg edgers ppa or not, 
but it's there now and it works, so I'm disinclined to mess 
with it. 

dpg-query for ati/radon:

libdrm-radeon1                2.4.37+git20120713.992e2afd-0 
    Userspace interface to radeon-specific kernel DRM services
xserver-xorg-video-radeon     1:6.99.99+git20120711.ef8a404 
    X.Org X server -- AMD/ATI Radeon display driver
xserver-xorg-video-ati        1:6.99.99+git20120711.ef8a404 
    X.Org X server -- AMD/ATI display driver wrapper

That'll teach me to try and mess with proprietary drivers...

Pete





More information about the xubuntu-users mailing list