[xubuntu-users] Password keyring doesn't get unlocked upon login

Joshua O'Leary joshua.oleary at btinternet.com
Sun Jul 8 16:38:04 UTC 2012


On Sun, 8 Jul 2012 17:27:59 +0100
Joshua O'Leary <joshua.oleary at btinternet.com> wrote:

> On Sun, 08 Jul 2012 12:23:08 -0004
> Jody Allen <jodyballen at gmail.com> wrote:
> 
> > On Sat, Jul 7, 2012 at 7:10 PM, Scott Moore <scottbomb at hotmail.com> wrote:
> > This is driving me nuts. I’ve googled and posted on ubuntuforums and STILL can’t find an answer to this seemingly common problem. Someone suggested installing seahorse and that didn’t do a bit of good. This pop-up shows up about 15-20 minutes after boot-up. If I’m in the middle of playing OpenArena, it pops up, my OpenArena screen is resized and pushed off to the side, and this thing demands my password (same password I used to log in). Of course, as I’m busy trying to pacify the pop-up, my player gets killed.
> >  
> > It happens on two different machines, both running Xubuntu 12.04. Can someone please tell me how to fix this??
> >  
> > Scott
> > I had the same problem and this worked for me:
> > 
> > http://laslow.net/2012/05/06/gnome-keyring-issues-in-ubuntu-12-04/
> > 
> > Turns out, a package upgrade (I was too lazy to identify which one) changed/reverted /etc/xdg/autostart/gnome-keyring-pkcs11.desktop and caused gnome-keyring-daemon to not load properly with XFCE. The fix was to find this line:
> > 
> > OnlyShowIn=GNOME;Unity
> > 
> > And append ;XFCE to it, making it:
> > 
> > OnlyShowIn=GNOME;Unity;XFCE
> > 
> > After a quick reboot everything worked as normal.
> 
> Thanks for the fix, this bug affects a number of programs that use gnome-keyring, including chromium / google chrome.
> 
> The package at fault here is gnome-keyring:
> 
> dpkg -S gnome-keyring-pkcs11.desktop
> gnome-keyring: /usr/share/gnome/autostart/gnome-keyring-pkcs11.desktop
> 
> Time to file a bug...
> 
> Joshua
> 
> -- 
> xubuntu-users mailing list
> xubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/xubuntu-users

Sorry that command was run on a Debian machine, the proper output on xbuntu is
gnome-keyring: /etc/xdg/autostart/gnome-keyring-pkcs11.desktop

I have reported a bug on Launchpad: https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/1022322

Please mark it as affecting you if you experience this issue.

Thanks,
Joshua




More information about the xubuntu-users mailing list