[xubuntu-users] 11.04 => 11.10 upgrade problems

John Thompson john at stolat.os2.dhs.org
Tue Feb 14 20:46:11 UTC 2012


I finally gave in and updated 11.04 to 11.10 on my Acer Aspire One 
netbook. I have two problems I have been unable to resolve:

1) Wireless networking does not work anymore. It worked fine with 
11.04, and it still works fine in Windows XP so I know it isn't a 
hardware issue. The kernel module "ath5k" loads, but the Network 
Manager cannot find a network to connect with. 

lshw sees the hardware:

  *-network
       description: Wireless interface
       product: AR242x / AR542x Wireless Network Adapter 
(PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci at 0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:24:2c:1a:72:57
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list 
ethernet physical wireless
       configuration: broadcast=yes driver=ath5k 
driverversion=3.0.0-16-generic firmware=N/A ip=192.168.1.66 
latency=0 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:18 memory:94100000-9410ffff

I can invoke ifconfig to wake up the interface and assign it an 
address:

wlan0     Link encap:Ethernet  HWaddr 00:24:2c:1a:72:57  
          inet addr:192.168.1.66  Bcast:192.168.1.255  
Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:58 errors:0 dropped:0 overruns:0 frame:0
          TX packets:157 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6554 (6.5 KB)  TX bytes:18836 (18.8 KB)

But I still am not connected to my wireless network.

iwconfig shows the interface:

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 
dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:0652-9261-54
          Power Management:off

And iwlist finds the signal from my access point:

wlan0     Scan completed :
          Cell 01 - Address: 64:0F:29:0F:81:A1
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=64/70  Signal level=-46 dBm  
                    Encryption key:on
                    ESSID:"2WIRE839"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 
Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000001d359107
                    Extra: Last beacon: 424ms ago
                    IE: Unknown: 00083257495245383339
                    IE: Unknown: 010882848B0C12961824
                    IE: Unknown: 030102
                    IE: Unknown: 0706555320010B1B
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C

But rfkill shows a soft block I am unable to clear:

0: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Is there a solution short of reverting to 11.04?

2) shutdown/restart does not work. It goes through all the motions, 
kills all the processes, but never manages to shut off the power or 
reboot. Screen is off, keyboard unresponsive, but the HD keeps 
spinning and it never gets any further in the shutdown or restart 
process unless I manually intervene by holding the power button down 
until the power goes off. 

What's up with that?

-- 

-John (john at os2.dhs.org)





More information about the xubuntu-users mailing list