[xubuntu-users] Updatedb and locate does not work

Ric Moore wayward4now at gmail.com
Sun Feb 5 07:09:16 UTC 2012

On 02/05/2012 12:33 AM, Lee Gold wrote:
> Sudo updatedb and locate does not consistantly work. Some stuff it
> locate finds other stuff it does not. I'm looking a file and folder
> names square in the face and trying them and it does not work. I do $
> sudo updatedb and then $ locate filename, tried catfish with same lack
> of results.
> What could be the problem? Always worked without a hitch. Using latest
> Xubuntu version.

Locate didn't use to search/catalog anything in /media, I suppose that 
somewhere there is a config file that determines where it searches and 
where it doesn't. Maybe someone knows.

heheheh, just did "locate locate" and found this:

ric at ima:/etc$ more updatedb.conf
# PRUNENAMES=".git .bzr .hg .svn"
PRUNEPATHS="/tmp /var/spool /media /home/.ecryptfs"
PRUNEFS="NFS nfs nfs4 rpc_pipefs afs binfmt_misc proc smbfs autofs 
iso9660 ncpfs
  coda devpts ftpfs devfs mfs shfs sysfs cifs lustre_lite tmpfs usbfs 
udf fuse.gl
usterfs fuse.sshfs curlftpfs ecryptfs fusesmb devtmpfs"
ric at ima:/etc$

...and there you have it, where it will search and which directories are 
excluded. :) Ric

More information about the xubuntu-users mailing list