[xubuntu-users] 11.04 webcam fail (was: ecryptfs problem after update)

John john at stolat.os2.dhs.org
Mon May 30 01:41:38 UTC 2011


On 2011-05-27, John Thompson <john at os2.dhs.org> wrote:
> I just updated my xubuntu-9.10 system to 10.10 (would have gone to 11.04, 
> but the installer kept crashing). I told the installer to leave my /home
> filesystem alone -- and it did -- but now I can't access the encrypted 
> data in my home directory. I have the unwrapped passphrase from the 9.10 
> installation but can't find any info on how to use it to access my data.
>
> I have tried using "ecryptfs-mount-private" but it complains "ERROR: 
> Encrypted private directory is not set up properly" and bails.
>
> Whither now?

I manager to install xubuntu-11.04 by using the "alternate" install media, 
yay! Used "ecryptfs-recover-private" to access my encrypted $HOME, copied 
it out to a new directory, updated pointers, etc. & seems to be working 
now, mostly. $HOME is unencrypted at the moment, but once I feel motivated 
I can change that. 

Alas, my built-in webcam is not working! It worked fine right out of the 
box with xubuntu-9.10, but no more. Hardware is Acer Aspire One "ZG8" with 
2Gb RAM. Cheese complained about "No device found," "v4l2-ctl --list-devices" 
complains "Failed to open /dev/video0: No such file or directory." Sure 'nuff, 
there is no "/dev/video0." Isn't the device mapper supposed to create these 
devices? Whatever. I do "mknod /dev/video0 c 81 0" to create the device file,
but no joy:

root at stolat:/dev# v4l2-ctl --list-devices
Failed to open /dev/video0: No such device or address
root at stolat:/dev# ls -l /dev/video0
crw-r--r-- 1 root root 81, 0 2011-05-29 20:25 /dev/video0

lsmod shows:

root at stolat:~# lsmod|grep uvc
uvcvideo               66851  0
videodev               75143  3 uvcvideo,bttv,v4l2_common

So what's wrong now?

-- 

-John (john at os2.dhs.org)





More information about the xubuntu-users mailing list