[xubuntu-users] /etc/init.d/rtorrent problem

Dominik Psenner dpsenner at gmail.com
Wed May 26 18:31:52 UTC 2010


Hi,

I'm fighting since some time now with rtorrent that won't come up using
the attached init script.

I installed it by which was indeed successful:
root at fuh:~# update-rc.d rtorrent defaults 99
root at fuh:~# ls /etc/rc*/*rtorrent*
/etc/rc0.d/K99rtorrent  /etc/rc2.d/S99rtorrent  /etc/rc4.d/S99rtorrent
/etc/rc6.d/K99rtorrent
/etc/rc1.d/K99rtorrent  /etc/rc3.d/S99rtorrent  /etc/rc5.d/S99rtorrent

The script is executable and all logfiles etc. exist. If I call it manually:
root at fuh:~# /etc/init.d/rtorrent start
 * Starting daemon-ized dtach session for rtorrent               [ OK ]

All looks fine and the daemon runs in the background. But unfortunatly
this is not true for the init. The script is being called (I can confirm
that because the log messages are there) but somehow the daemon is not
started or does not survive at some later point. This script here is now
based upon dtach, but the same problem was prior there when using
screen. I installed the xubuntu server I'm running here in february.
Should be ubuntu 10.04 or some.

Now to the question: WTF is going on there or what am I doing wrong? The
$PATH is fine and logging 'which rtorrent' was fine. I'm quite sure it
must be something with the init.d but I couldn't figure out until now
what exactly. Also because I don't know where to start searching for it.

Greetings,
Domi
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: rtorrent
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20100526/117562ac/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/xubuntu-users/attachments/20100526/117562ac/attachment.pgp>


More information about the xubuntu-users mailing list