[xubuntu-users] wireless interface will not start

Nils Kassube kassube at gmx.net
Tue Oct 6 07:46:08 UTC 2009

Lee Gold wrote:
> When I use a different wlan interface, shutdown, then bootup wanting
> to use the built in one, Xubuntu does not "remember". The built in
> wlan0 will not activate, it shows up on ifconfig but not command i
> know of ups it and pressing the wireless button on the laptop will
> not turn it on. The only way to get it back is to restart and boot
> WinXP. Somehow booting XP activates the  wlan0, I don't even have to
> login, then from the XP login page I restart and Xubuntu will have
> wlan activated.

You could check your BIOS if there is a setting for WLAN. In the BIOS of 
my laptop I have a "wireless default setting" which can be enabled or 
disabled. It has to be enabled for Ubuntu. And I remember I have seen 
another machine which had the options "disabled" and "no change" where 
the "no change" option worked, IIRC.

> This is a pain. Is there command or tweak to fix (9.04) w/WICD
> manager? I tried  > ifconfig wlan up, things like that...

The problem is that the txpower is switched off. Then even if you can up 
the interface with ifconfig, it still doesn't work. You could try the 

sudo iwconfig wlan0 txpower on

or was it "txpower 1" instead of "txpower on"? I'm not sure but you can 
try both because the worst case is that the command doesn't work. Sorry, 
I don't have a wireless interface handy to try it.


More information about the xubuntu-users mailing list