[xubuntu-users] 7z files in Thunar

John Alfred Nathanael Chee cheecheeo at gmail.com
Fri Dec 4 22:41:50 UTC 2009

On Fri, Dec 4, 2009 at 04:24, Michele Mor <m_mor at mail15.com> wrote:
> Hi.
> Some time ago I zipped a file from Windows with 7zip and I chose the native format 7z.Few days ago I tried to unzip that file from Xubuntu, using Thunar file manager.I selected the file, right-click and chose: "extract here".I had an error message stating that it was not a valid archive.I went into Synaptic, checked for 7z, and with my surprise Thunar/File Roller already had 7z listed as a supported format.Just to be sure, I uninstalled and installed that package again.Needless to say, I had the same error.
> I booted the same laptop into Windows (dual boot Xubuntu-Windows), intalled 7-zip and I could extract that file without any issue.
> Can anyone explain me what caused the issue in Linux?
> Thanks.Michele

file-roller suggests the package p7zip or p7zip-full be installed with it.

'sudo apt-get install p7zip' (or installation of the p7zip package
through Synaptic) should enable file-roller to unarchive 7z files.

Love in Jesus Christ, John Alfred Nathanael Chee

More information about the xubuntu-users mailing list