[xubuntu-users] Could not find internet address

Daan Hoogland dhoogland at interestate.nl
Sun Nov 2 13:30:19 UTC 2008


Hello Nils,

Thank you for your help. This is what I did and saw:

In Terminal I entered 'gksu Mousepad /etc/hosts' and I made the two
first lines as you told me.

Then I entered 'nm-applet &'. The answer was not a simple OK but a
message I did not write down. I got the idea that something was not OK.

When I looked at the Desktop I noticed the network icon I missed
before has returned to the screen (2 monitors connected to each other
with a cross).

As you mentioned I tried to configure the wired connection manually.
The window 'Network Connections' has 5 tabs: wired/wireless/mobile
broadband/vpn/dsl.
'wired' shows the existing situation: Auto eth0 - never (the word
'never' seems to pose the problem to me).
Also 3 buttons can be seen: add/edit/delete.

Editing the wired 'auto eth0' connection gives a submenu with 3 tabs:
wired/802.1 x security/IPv4 settings.

Under 'wired' one can choose to enable 2 items: connect automatically
and system setting. Both choices are unabled by default. I kept it
this way (I enabled both choices but that did not seem to make a
difference).
The subscreen also shows some values: MAC address: 00:D0:59:14:37:41
and MTU - automatic. I didn't change these values either.

Under 'IPv4 settings' one can choose among 5 methods: automatic
(DHCP)/automatic (DHCP) addresses only/manual/link-local only/shared
to other computers.
Only when I choose 'manual' the button 'OK' at the end becomes grey,
meaning that the changes I make into this menu (entered IP addresses
for pc/netmask/gateway and DNS servers) cannot be saved.


At the end I entered your last given command:
sudo /etc/init.d/networking restart. The answer was: reconfiguring
network interfaces [OK}.

Connection to the internet is still not possible. To me the problem
seems that I cannot give this laptop-pc an IP-address.

Do you have any more recommendations to improve the situation?

Thank you very much in advance, kind regards, Daan

Nils Kassube wrote:
> Daan Hoogland wrote:
>> It may be that I managed to change the addresses 127.0.0.1 and
>> 127.0.1.1 into:
>>
>> IP address laptop: 192.168.2.100
>> gateway address: 192.168.2.1
> 
> Where did you (try to) put these lines? In /etc/hosts that would be wrong. 
> You definitely need the loopback interface lines (IP addresses starting 
> with 127). We'll talk about the 192 addresses later, but first lets 
> modify /etc/hosts. You need root privilege to modify that file. Therefore 
> use the command
> 
> gksu mousepad /etc/hosts
> 
> in a terminal to edit the file. Then change the file so it gets this 
> contents:
> 
> 127.0.0.1 localhost
> 127.0.1.1 daan-laptop.werkgroep daan-laptop
> 
> You may keep the IPV6 lines which you had in the original file but they 
> are not vital. However DO remove the lines with 192.168.2.100 and 
> 192.168.2.1 if they exist. Then save the file.
> 
>> Even the menu item 
>> Network Manager has disappeared from the menu. 
> 
> You can restart the network manager applet with the command
> 
> nm-applet &
> 
> in a terminal and try if you can browse the internet already.
> 
> If that doesn't work, use the manual configuration of the network manager. 
> Select the wired connection and click on the properties button. Uncheck 
> the "Enable roaming mode" option and select "static IP address" for the 
> configuration. Enter the IP address 192.168.2.100 and the gateway address 
> 192.168.2.1 (the subnet mask will be added automatically). Now click OK. 
> Now select the DNS tab. You need at least one DNS server. Click tha "+ 
> Add" button and type the address 192.168.2.1 because I suppose you are 
> using a router which is your DNS server as well. If you have some other 
> configuration you would use the address of you ISPs DNS server. Finally 
> close the configuration window and in a terminal enter this command:
> 
> sudo /etc/init.d/networking restart
> 
> Now it should really be possible to browse the internet.
> 
>> David Collins wrote:
>>> Daan,
>>>
>>> I suggest you take the error message suggestion literally - try
>>> changing your first 2 lines to -
>>>
>>> 127.0.0.1 <http://127.0.0.1> localhost
>>> 127.0.1.1 <http://127.0.1.1> daan-laptop.werkgroep daan-laptop
> 
> That is totally wrong. <http://127.0.0.1> has nothing to do with the hosts 
> file.
> 
> 
> Nils
> 





More information about the xubuntu-users mailing list